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About this guide

The One Identity Manager User Guide for One Identity Manager Tools User Interface is
intended for end users, system administrators, consultants, analysts, and other IT
professionals who want to learn about secure handling of One Identity Manager tools,
especially the Manager and the Designer.

The interfaces of the Manager and Designer have a similar layout. The basic elements and
functions of the user interface are the same for all of the One Identity Manager tools. The
user interface layout is explained based on the example of the Manager. Default functions
used in connection with the Manager Designer are described.

NOTE: This guide describes One Identity Manager functionality available to the default
user. It is possible that not all the functions described here are available to you. This
depends on your system configuration and permissions.

The One Identity Manager Operational Guide describes the special tasks and functions
offered by the two tools to support One Identity Manager while it is running.

The Manager is the main administration tool for setting up information about employees
and their identities. It displays and maintains all the data required for the administration
of employees, their user accounts, permissions, and company-specific roles in a One
Identity Manager network. Company resources employees require can be entered and
assigned to them.

You can also use the Manager to:

o Define custom IT policies.
« Setup an IT Shop from which company resources and assignments can be requested.

« Set up special approval processes for authorizing requests and checking compliance
to IT policy.

« Set up attestation procedures for regularly testing the correctness of data about
employees or roles and their assignments.

By implementing One Identity Manager application roles, every One Identity Manager user
obtains only those permissions they require to fulfill necessary administrative duties.

The Designer is the main configuration component in One Identity Manager. The program
offers an overview of the entire One Identity Manager data model. It enables the
configuration of global system settings, for example, languages, or configuration
parameters such as customizing user interfaces for the various administration tools. It also
allows the permissions structure to consolidate the various administrative tasks of each
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user and user groups. Another important task is the definition of workflows for technically
illustrating the administration procedures in the company.

Available documentation

You can access One Identity Manager documentation in the Manager and in the Designer by
selecting the Help > Search menu item. The online version of One Identity Manager
documentation is available in the Support portal under Technical Documentation. You will
find videos with additional information at www.YouTube.com/Oneldentity.

One Identity Manager 8.2 User Guide for One Identity Manager Tools
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One Identity Manager tools user
interface

The user interface layout is explained based on the example of the Manager. The basic
elements and functions of the user interface are the same for all of the One Identity
Manager tools.

Certain components of the One Identity Manager’s graphical user interface are stored in
the One Identity Manager schema and can be tailored to suit customer requirements.
Menu items in the navigation structure, interface forms, and task definitions can be
configured in this way.

Menu items, interface forms, and task definitions are assigned to permissions groups. The
user's effective components of the user interface depend on the authentication module
used for logging in to the One Identity Manager tools. If a user logs in to a One Identity
Manager tool, a system user is found and the available menu items, interface forms, task
definitions, and individual program functions are identified depending on the permission
groups to which this system user belongs and the adapted user interface is loaded.

Data is displayed as objects in the user interface. User interface objects are meta-objects.
You provide a selection of configurable elements that describes how the data stored in the
database is perceived. These objects enable data to be distinguished by specific properties.
They provide an additional control function for configuring the user interface. Hence,
interface forms and tasks are linked to object definitions, which means that different forms
and tasks are displayed in the user interface depending on which object is selected.

For more information about how to customize the user interface to your specific
requirements, see the One Identity Manager Configuration Guide.

The user interface layout

You can control the One Identity Manager tools' graphical user interface with using mouse
and key combinations. A minimum screen resolution of 1280 x 1024 pixels is recommended
with at least 16 bit color for the best display.

The user interface consists of the following components:
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Title bar

In the title bar, you can see the program icon, program name, and connected
database shown using the notation <user>@<database server>\<database
(description)>.

Menu bar

The menu bar gives you different menus and menu items. The menus Database and
Help are always there. If a database is open, you can see more menus.

Toolbar

Each program component comes with its own toolbar.

Editing section

The editing section has different views for displaying and editing data.
Status bar

The status bar displays different status data. Some status data is shown by way
of icons. Which icons are displayed is partially dependent on the program
settings selected.

Figure 1: Manager user interface
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Using the help in the Manager

You can access One Identity Manager documentation in the Manager by selecting the Help
> Search in local help menu item.

You can display the help for the individual Manager forms using the Help > Form help
menu item or F1.

With some forms, a separate dialog box appears. Use the help icon (?) in the title bar of the
dialog window to open the help for a dialog window.

Every form also has a help display for the columns shown. Clicking on the help icon @
changes the cursor into the help icon. You can then click a column description to display
tips about using the column in the form of tooltips.

Status bar information in the Manager

The status bar displays different status data. Some status data is shown by way of icons.
Which icons are displayed is partially dependent on the program settings selected. The
status bar comes in different colors.

Table 1: Meaning of the colors

Color Meaning

none Development environment database is connected.
Red Simulation mode is enabled.

Green Test environment database is connected.

Yellow Productive environment database is connected.

Table 2: General icons in the status bar

Icon Meaning

- Current user.

& The DBQueue Processor was stopped.

=) The services were stopped.

= The database is connected.

El Database status (database activity such as loading or saving objects).
The database must be compiled.

& The database is in recovery mode. It is not possible to process data at this time.

One Identity Manager 8.2 User Guide for One Identity Manager Tools
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Icon

Meaning

There are invalid script assemblies. The database must be compiled.

No connection.

Display for step-by-step preparation of a database update. All database users will
be informed about the upcoming update. The system does accept anymore
processes.

Display for step-by-step preparation of a database update. Users cannot log in to
the database anymore. All running processes will still be completed.

Display for step-by-step preparation of a database update. The database is
updating.

Table 3: Additional icon in the status bar in the Manager

Icon Meaning

& Quick edit mode is enabled.

(e The field definitions (technical tables and column names) are displayed.
ot Additional information on the navigation objects is displayed.

=) The program is in simulation mode.

o The system data was modified.

A A warning has been written to the error log.

o An error message has been written to the error log.

The Manager's status bar also shows the following information:

« The connected database in the following format: <Server>\<database (description)>

« The definition of the current object

« The name of the activated form in the following format: <logical form>

[ (<physical form>)]

TIP: Double-click the name in the status bar to copy the object definition, the form name
or the database connection name to the clipboard.

Related topics

The user interface layout on page 9

Features of the document view on page 30

Displaying the column names on page 34

Detailed information about the user interface on page 60

Current user on page 13

One Identity Manager 8.2 User Guide for One Identity Manager Tools
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Current user

The program's status bar shows the name of the current user. Depending on the
authentication module used, this can be the full name of the person or the designation of
the current system user. Use the tooltip to show the full name of the current user and the
current system user.

To get more information about the current user

. To display user information, double-click the & icon in the program status bar.

Table 4: Extra information about the current user

Property

Meaning

System users

Authenticated
by

Employee UID
(UserUID)

SQL access
level

Read-only

Dynamic user

Administrative
user

Remarks

Permissions
group

Program
functions

Name of system user

Name of the authentication module used for logging in.

Unique ID for the current user’s employee if an employee related authen-
tication module is used to log in.

Access level of the database server used to login.

The system user has only has read permissions. Modification to data are
not possible.

The current user uses a dynamic system user. Dynamic system users
are applied when a role-based authentication module is used.

The current user uses an administrative system user.

More details about the system user in use.

Permissions groups that are assigned to the system user. The permis-
sions groups determine the user's user interface and object permissions.

Program functions assigned to the system user The menu items and
functions available depend on the program functions.

Changing the password of the logged in user

To change the password:

1. Select the Database > Change password menu item and enter the following
information:

One Identity Manager 8.2 User Guide for One Identity Manager Tools
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. Old password: Enter the previous password.

« New password: Enter the new password.

. Confirm new password: Enter the new password again.

2. Save with OK.

Menu items in the Manager

Table 5: Meaning of items in the menu bar

NOTE: The password must comply with the password policy. To display the
requirements, click the Password requirements link.

Menu Menu item Meaning Shortcut
Database New connec- Establishes a database connection. Ctrl + Shift
tion +N

Close connec-
tion

Change
management

Start/stop
simulation

Change

management

Export data

Show deferred
operations

(GNE IDENTITY
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Closes the current database connection.

Opens a dialog box for editing change labels.
This menu item is only available in expert
mode.

The program switches to simulation mode or to
working mode.

For detailed information about the simulation,
see the One Identity Manager Operational
Guide.

Opens a dialog box for editing change labels.
This menu item is only available in expert
mode.

For detailed information about working with
change labels, see the One Identity Manager
Operational Guide.

A form opens in which you can confirm the
export data.

For detailed information about exporting data,
see the One Identity Manager Operational
Guide.

Deferred operations are displayed.

For detailed information about planning activ-
ation times, see the One Identity Manager
Operational Guide.

One Identity Manager 8.2 User Guide for One Identity Manager Tools
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Menu Menu item Meaning Shortcut
Pending Shows changes pending for objects and their
changes processing status.
Check data This opens the consistency check form.
consistency For detailed information on checking data
consistency, see the One Identity Manager
Operational Guide.
Change The logged in user can change the password.
password
Settings For configuring general program settings.
Exit Exits the program. Alt + F4
Object New A new object with the displayed object type is Ctrl + N
added.
Save Saves all changes to an object. Ctrl + S
Set the change You can set the time of the change.
time stamp For detailed information about planning activ-
ation times, see the One Identity Manager
Operational Guide.
Delete Deletes selected object. Ctrl + D
Set the You can set the time that the object is deleted.
deletion time For detailed information about planning activ-
ation times, see the One Identity Manager
Operational Guide.
Undo delete After confirmation, the deletion process is
reversed. This option is only available if the
object was marked for deletion.
Discard Any unsaved form entries are discarded. Ctrl + Shift
changes +D
Reload The object is reloaded. Ctrl + F5
Properties Show other properties of the active object. This
menu item is only available in expert mode.
Reapply All object templates are reapplied. This menu
templates item is available only in the object's main data
form.
Add to Add the current object to your favorites or Ctrl + B

favorites or
remove from

(GNE IDENTITY
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remove it from your favorites. These options
are shown alternately.
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Menu Menu item Meaning Shortcut

favorites

Back Shows the previous form in the order in which Alt + left
the forms were viewed. arrow

Forward Shows the next form in the order in which the Alt + right
forms were viewed. arrow key

X One Identity Manager 8.2 User Guide for One Identity Manager Tools
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Menu Menu item Meaning Shortcut
View Navigation Activates the navigation view. Ctrl + Q

Result list Opens the result list. Ctrl + R

Documents Enables the current document. Ctrl + O

Favorites Shows or hides the favorites list.

Tasks Shows or hides the task view.

Error log Shows or hides the error log.

Process Shows or hides the process view.

Information

TimeTrace Shows or hides the TimeTrace.

For detailed information about TimeTrace, see
the One Identity Manager Operational Guide.

Database Shows or hides the database search.

search

Start page The start page is displayed.

Enable quick The quick editing of objects is enabled or

edit mode disabled.

Close current  Closes the current document. F4

document

Close all Closes all open documents.

documents

Enable Shows all open documents. You can toggle from

document one open document to the next.

Layout Changes the layout of the program’s interface.  Ctrl + Shift
+ L (loads
in expert
mode)

Display field The technical table and column names are

definitions shown in the editing forms. This menu item is

only available in expert mode.

Display Displays the loaded navigation objects. This

navigation entry is available only if the program setting

objects Show additional navigation information is

enabled.
Plugins Name of the Shows the available plugins so that you can
plugin. apply them.

(GNE IDENTITY
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Menu Menu item Meaning Shortcut

Help Community Opens the One Identity Manager community
website.

Support portal Opens the One Identity Manager product
support website.

Training Opens the One Identity Manager training portal
website.

Online Opens the One Identity Manager documentation

documentation website.

Search Opens the search dialog box.

Form help Opens the help for this form. F1

Info Shows the version information for program.

Table 6: Toolbar functions

Icon Meaning

i Show homepage.

€ Show the previous form in the order in which the forms were viewed. You can see
the form history from the selection menu. You can select any form you wish from
here.

> Show the next form in the order in which the forms were viewed. You can see the
form history from the selection menu. You can select any form you wish from
here.

& Show or hide the database search dialog.

Add a new object of that object type.

B Saves changes.
fS Set time at which to save an object's changes. For detailed information about

planning activation times, see the One Identity Manager Operational Guide.

8 Deletes object.

& Set time at which to delete the selected object. For detailed information about
planning activation times, see the One Identity Manager Operational Guide.

& Redo delete. This option is only available if the object was marked for deletion.

p>) Discard unsaved changes from the form.

o Update object.

* Add object to favorites.

* Remove object from favorites.

= Print form. Printer settings are configured in the configuration menu.
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Views in the Manager

The editing area in the Manager has different views for displaying and editing data.

Table 7: Views in the editing area

View Description

Navigation The navigation view shows suggested navigation starting points for the
view current user.

Result list ~ When you select a menu item in the navigation view, the result lists shows
all the objects that correspond to the object definition and the conditions of
the menu item.

Document  The document view shows the forms to edit a selected object.
view

Task view  The task view shows the tasks and reports available for an object.

Favorites This view is used to compile individual menu items into a user-specific
list favorites list.

Error log The error log shows errors and warnings that occurred when working with
the Manager. For detailed information about Error log, see the One Identity
Manager Process Monitoring and Troubleshooting Guide.

Process This view is used to analyze the process data resulting from data changes.
Information For detailed information about the evaluation of process information, see
the One Identity Manager Operational Guide.

TimeTrace In this view you can track changes to an object that were made up to any
point in the past. For detailed information about TimeTrace, see the One
Identity Manager Operational Guide.

Detailed information about this topic

« The user interface layout on page 9

« Features in the navigation view on page 21
o Functions in the result list on page 25

« Features of the document view on page 30
o Features in the task view on page 28

« Features in the favorites list on page 29

One Identity Manager 8.2 User Guide for One Identity Manager Tools
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Layout mode in the Manager

The Manager can display the editing area in standard mode or expert mode. The layout of
the default view varies between modes. The current user's layout is saved in the user
configuration so that when you restart the program the last layout you used is shown.

Detailed information about this topic

« Simple layout mode in the Manager on page 20

« Expert mode in the Manager on page 20

Simple layout mode in the Manager

The simple layout mode provides two other layouts in addition to the default layout.

To select the simple layout mode in the Manager

1. Inthe Manager, select the Database > Settings menu item.

2. On the User tab, disable the Enable expert mode option.

To change the layout in the Manager

« To specify a layout in the Manager, select the View > Layout > View 1 or the
View > Layout > View 2 menu item.

« To reset the layout to the default setting in the Manager, select the View > Layout
> Restore default menu item.

Related topics

o Expert mode in the Manager on page 20

Expert mode in the Manager

In expert mode you can use the mouse to change the position and size of the editing
windows in the user interface. You can use the pin in the title bar of a window to enable or
disable the auto-hide mode. If this mode is enabled, the selected window slides out of or
into the area. To select a window in auto-hide mode, use the symbol in the navigation
toolbar on the side. There are other menu items and functions available in expert mode.

To select expert mode in the Manager

1. Inthe Manager, select the Database > Settings menu item.

2. On the User tab, enable the Enable expert mode option.

One Identity Manager 8.2 User Guide for One Identity Manager Tools
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To change the layout in the Manager

o To save the layout in the Manager, select the View > Layout > Save menu item
and enter a Name.

o To load a layout in the Manager, select the View > Layout > Load or Ctrl + Shift
+ L menu item.

« To reset the layout to the default setting in the Manager, select the View > Layout
> Restore default menu item.

Table 8: Other menu items in expert mode

Menu Menu item Meaning Shortcut
Database Change manage- Opens a dialog box for editing change labels.

ment
View Display field The technical table and column names are

definitions shown in the editing forms.

Layout > Save Save the current layout.

Layout > Load Load a layout. Ctrl +
Shift + L

Object Properties Show other properties of the active object.

Table 9: Additional context menu items

Context Meaning
menu

Definition This shows advanced technical information about configuring a menu item.
This menu item is only available in navigation view. You must also enable the
Show additional navigation information program setting.

Properties Shows other properties of the object.

Related topics

« Simple layout mode in the Manager on page 20
« Displaying the column names on page 34
« Detailed information about the user interface on page 60

« Displaying extended properties for objects on page 78

Features in the navigation view

The navigation structure of the user interface is hierarchical and allows users to drill down
to the selection of an object definition. The top level of the hierarchy is used to classify the
data managed by One Identity Manager into specified categories. Categories include a

One Identity Manager 8.2 User Guide for One Identity Manager Tools
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range of different menu items. Select a category on the category tab. You can configure
additional settings in the configuration menu.

Figure 2: Navigation view in the Manager with the "Organizations" category

as an example
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TIP: If menu items are linked to preprocessor-relevant configuration parameters, you
can display the preprocessor conditions behind the menu items. To do this, enable the
program setting Show additional navigation information.

Specific mouse commands are available:

« You can open or close a menu item by double-clicking on the entry name.

o Click the name of the menu item to show the found objects in the result list, as long
as a corresponding object for that object type is found. If there are no objects for a
defined menu item, an empty result list is shown.

Table 10: General key combinations for the navigation view

Shortcut

Action

Ctrl + Q

Activate navigation structure.

Down arrow, up arrow, page down key, page up key, Move up/down the navigation

home, end

<+> or right arrow key

(GNE IDENTITY
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structure.

Open menu item.
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Shortcut Action

<-> or left arrow key Close menu item.
Data Select an entry.
F5 Update the navigation view.

The navigation view has its own context menu. Menu commands are shown or hidden
depending on the selected menu item.

Table 11: Entries in the context menu of the navigation view in the Manager

Context Meaning

Menu Item

New A new object with the selected object type is added. Already entered insert
values are applied.

Open on The object is opened in a new form in the document view.

new tab

Refresh Updates the navigation view.

view

Search The system searches for objects in the navigation.

Add to my Copies the selected menu item to the My One Identity Manager
One Identity category. This helps you navigate quickly to frequently used menu items.

Manager The data is saved in the user configuration.

Add to Adds the selected object to your favorites.

favorites

Remove Removes the selected object from your favorites.

from

favorites

Show The process view shows the process data for the selected object. For
process detailed information about the evaluation of process information, see the

information One Identity Manager Operational Guide.

Tasks The available tasks for the object are displayed and you can run the
desired task.

Definition Shows detailed information about configuring the menu item. This menu
item is only available in expert mode.

Show Shows the deferred operations for the objects in this category. For detailed
deferred information about planning activation times, see the One Identity Manager
operations  Operational Guide.

The navigation view features a configuration bar with its own configuration menu.
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To open the configuration menu of the navigation view

o Use the >> button.

Table 12: Entries in the navigation view configuration menu

Entry in config- Meaning
uration menu

Show more categor- More categories are shown in the list. The category icon is

ies removed from the configuration bar.

Show fewer categor- More categories in the list are hidden. These are represented by
ies icons in the configuration bar.

Settings Opens the program settings.

Add or remove Categories can be removed from or added to the list.

categories

Related topics

« My One Identity Manager on page 24
« Manager program settings on page 56
« Detailed information about the user interface on page 60

My One Identity Manager

The category My One Identity Manager shows the user-specific entries in the Manager.
All the available infosystems and specific reports for the current user are shown here. In
this category you can create and apply user-specific filters.

To copy a menu item to the My Manager category in One Identity Manager

o Click Add to My .One Identity Manager

This helps you navigate quickly to frequently used menu items. The data is saved in
the user configuration.

To delete a menu item from the My Manager category in One Identity Manager
o Click Remove from My .One Identity Manager

Table 13: Additional entries in the context menu for the my One Identity

Manager category

Context Menu Meaning
Item

Remove from My Removes the selected menu item from this category.
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Context Menu Meaning
Item

One Identity

Manager

New filter Search criteria for database queries are saved as filters.

Edit filter The selected filter can be edited.

Remove filter Deletes the selected filter.

Attaching The selected filter is attached to a category. When you select a
category, all objects that correspond to the filter are shown on a
separate form page.

Export filter Exports the selected filter as an XML file.

Import filter Imports filters that exist as XML files.

Related topics

« Advanced database search on page 72
« Attaching filters in the Manager on page 69

« Exporting and importing filters in the Manager on page 68

Functions in the result list

The result list shows all the objects that correspond to the object definition and the
conditions of the selected menu entry. Select an entry from the list. The object is loaded
and the first available form appears in the document view. If there are no objects for
the selected menu entry, the document view continues to show the most recently
selected form.

A list title is shown in the title bar of the result list. This depends on which menu item in the
navigation structure was used to select the object. This list title also contains the number of
elements in a list.
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Figure 3: Example for result list in the Manager
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In the result list, an object is marked with the symbol that was set when the interface was
configured. If an object is deleted by the One Identity Manager Service, the object is
initially marked for deletion. It is permanently deleted only after a set time period. Objects
that are selected for deletion are marked with the icon #.

| NOTE: Objects marked for deletion are struck through on the overview form.
By default, an object is loaded by means of a double-click and the first available form is
displayed in the document view.

To load objects with a single click

1. Select the Database > Settings menu item.

2. On the User tab, activate the Use single clicks option.

Select single objects one after the other to update the opened form in the document view.
Only one form is open at a time.

To display multiple forms in the document view:

o Use Alt + Click or click Open on new tab from the context menu to open
the objects.

This means that you can quickly switch between objects without having to reload the
object from the list again. The forms stay open when you switch between categories.

To edit multiple objects at the same time:

1. Use Shift + selection or Ctrl + selection to select the objects in the result list.

2. Open the main data form using Input, the corresponding icon in the result list or the
Tasks > Change main data context menu item.

New objects are displayed below the Added entry in the result list. The objects used are
displayed below the Recently used entry in the result list.

To display recently used objects in the Manager

1. Select the Database > Settings menu item.

2. Onthe User tab, activate the Show recently used objects option and enter the
Object type count.
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Table 14: Common key combinations for the result list in the Manager

Shortcut

Action

Ctrl + R

Enable result list.

Down arrow, up arrow, page down key, Move up/down the list.
page up key, home, end

Enter, Alt + Enter Open an item.

Shift + selection + Enter , Ctrl + Select multiple entries and open the main data
selection + Enter form to edit multiple entries.

F5 Update the result list.

The result list has its own toolbar and context menu.

Table 15: Toolbar features in the Manager

Icon Function
@ Edit. Opens the main data form.
New. Creates a new object.
Delete. Deletes the object.
&l Undo delete. Redo delete.
o Reload the data. Reloads the objects.
Q Search. Search in result list.
Y Filter. Filter result list.
& Export result list.

Table 16: Entries in the result list context menu in the Manager

Context Meaning
Menu
Item
New A new object with the selected object type is added. Already entered insert
values are applied.
Delete The selected object is deleted once the security prompt is confirmed.
Undo After confirming the security prompt, the object is undeleted. This option is
delete only available if the object was marked for deletion.
Open on The object is opened in a new form in the document view.
new tab
Search The system searches for objects in the navigation.
X One Identity Manager 8.2 User Guide for One Identity Manager Tools
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Context Meaning

Menu

Item

Add to Adds the selected object to your favorites.

favorites

Remove Removes the selected object from your favorites.

from

favorites

Show The process view shows the process data for the selected object. For

process detailed information about the evaluation of process information, see the

information One Identity Manager Operational Guide.

Tasks The available tasks for the object are displayed and you can run the desired
task.

Properties  Show other properties of the active object. This menu item is only available
in expert mode.

Related topics
« Expert mode in the Manager on page 20
« Limiting list sizes using simple filters on page 62

Displaying extended properties for objects on page 78

« Multiple object edit in the Manager on page 79

Features in the task view

When you select an object, the task view shows the tasks and title of available reports. To
run a task or open a report, select an item in the task view. Use the tooltip to show a more
detailed description of a task or a report.
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Figure 4: Task view in the Manager
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o Applicationrole overview
E' Change master data
g Assign extended properties

@ Reports #

o Overview ofall assignments

TIP: If tasks are linked to preprocessor-relevant configuration parameters, the
preprocessor conditions are shown behind the tasks. To do this, enable the program
setting Show additional navigation information.

Related topics

« Detailed information about the user interface on page 60

Features in the favorites list

Links to frequently visited objects are stored in the favorites list in the Manager.

Figure 5: Favorites list in the Manager

R
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To copy an entry to the favorites in the Manager

« Inthe Manager, select the entry and select the Add to favorites context menu.
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To delete an entry from the favorites in the Manager

o In the Manager, select the entry and select the Remove from favorites
context menu.

The favorites list has its own toolbar and context menu.

Table 17: Meaning of entries in the special toolbar in the Manager

Icon Meaning

2i Sort your favorites alphabetically.
=4 Sort your favorites by object type.
1] Delete all favorites.

= Delete selected favorites.

Table 18: Entries in the context menu of the favorites list in the Manager

Context Meaning
Menu Item

Open on new The object is opened in a new form in the document view.
tab

Search The system looks for objects in the favorites list.

Remove The selected favorites are removed from the favorites list.

selected

favorites

Tasks A submenu shows all the tasks that are available for the selected object.

Select one of the tasks to open the relevant form.

Properties Show other properties of the active object. This menu item is only
available in expert mode.

Related topics

« Displaying extended properties for objects on page 78

Features of the document view

When you select an object in the result list, the first available form is displayed in
document view. As a minimum, the following forms are displayed for each editable object:

o Overview form

This form is used only to display selected data for an object.
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« Main data form

Use this form to change the object data.

Every form has a form tab bar that displays the selected object according to a set display
template. For objects that were marked as pending during a synchronization, the display
template is provided with the [Outstanding] ID.

Every form has a context menu with form-specific entries. In expert mode, you can use the
Properties entry in the form context menu to view additional object properties and the
permissions.

Figure 6: Form in the Manager
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To open the forms for an object:

« When you select an object on the result list, the first form always opens (usually the
overview form).

« From the result list, select single objects one after the other to update the opened
form in the document view. Only one form is open at a time.

o To open other forms, select the task from the task view or from the form's
context menu.

To display multiple forms in the document view:

o Use Alt + Click or the Open on new tab context menu to open the objects.

This means that you can quickly switch between objects without having to reload the
object from the list again. The forms stay open when you switch between categories.

To close the forms:

o From the menu, select the View > Close active document or the View > Close
all documents menu item.

By default, an object's overview form is displayed first. You can, however, configure the
program to show the edit form for the object first, which allows faster editing.
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To enable quick edit mode:

« Inthe Manager, use the @ icon in the result list.
It is only possible to quick edit the selected object.

o Select the View > Enable quick edit mode menu item.
Restart the program to enable quick edit mode.

o From the Database > Settings menu item, select the Enable quick edit mode
program setting.

Quick edit mode remains enabled even if you restart the program.
The status bar in the Manager also shows the following information when you open a form:

« The definition of the current object

. The name of the activated form in the following format: <logical form>
[(<physical form>)]

TIP: Double-click the name in the status bar to copy the object definition and the form
name to the clipboard.

The forms use different controls and functions.

Related topics

« Detailed information about the user interface on page 60

« Displaying extended properties for objects on page 78

Overview form

Form elements are used to present the information on the overview forms.
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Figure 7: Example of elements in an overview form
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The display text of the menu item, the display text for the objects to be shown and the
menu item icon are displayed in the header of a form element. Other data represents the
object properties and values. There is a tooltip for each property showing a description for
use. Some form element entries are highlighted in color when you click on them with the
mouse. Then you can click on the entry to switch to the referenced object.

If the form element is used for mapping lists, the items are displayed with their names.
The number of items is shown in the form element header. There is also anicon in the form
element header for showing and hiding the items. A tooltip is also shown for the list items.

Table 19: Form element icon

Icon Meaning
A Show list items.
e Hide list items.

NOTE: Objects marked for deletion and outstanding objects are struck through on the
overview form.

Input field

Input fields are used to edit strings, numbers, and dates. A default context menu is
available for input fields. Mandatory input fields are marked with a triangle | . Whether an
input field is required or not depends on the minimum column length defined in the model
tables. Other required fields are defined in the customizers.
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Figure 8: Input field with required field

Last name Harris

TIP: You can use the Ctrl + Alt + Enter key combination to enlarge the input fields for
entering multiline texts.

Labeling changed data

Changes to data are labeled with extra icons in front of the modified value. As long as the
changes have not been saved, you can undo the changes by clicking on the icon.

Figure 9: Labeling changed data
Last name @ |

Table 20: Labeling the input fields when data changes

Icon Meaning
© Changed value. The value is not yet saved. Click the icon to discard the
change.

The value will be changed at a specified time. You can change the value only at
the specified time.

The value will be changed at a specified time.

For detailed information about planning activation times, see the One Identity Manager
Operational Guide.

Displaying the column names

The column name is shown for every input field. If the full column name is too long to
display, itis shortened with [...]. Use a tooltip to display the full name.

In the Manager, you can display the technical names of the columns in expert mode. in the
format column@table.

To display the technical names in expert mode in the Manager

« Inthe Manager, select the View > Show field definition menu item.

Related topics

« Expert mode in the Manager on page 20
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Translating entries

For more information about localization in One Identity Manager, see in the One Identity
Manager Configuration Guide.

If a column is marked as multilingual, an extra button & is displayed next to the input field.
NOTE:

o The value is always entered in the input field in the specified default language. The
value is then translated into the required languages.

« The translations are only used to display a value, for example, in the overview
form or in lists. The input fields to be edited still show the value entered in the
default language.

« You can edit translations in different places. When you change a translation, all
those places are shown. Before changing a translation, check in the Designer about
how it is used.

« Users can only edit object and column translations for which they have
permissions.

o To edit all translations, users require the Allow translation of text data
regardless of the edit permissions for the base object program function
(Common_Translation).

To translate an entry:

1. Click & beside the input field to open the dialog window for entering the translations.
2. Use next to the translation field to delete a translation.

| NOTE: You can use the ¥ button beside the translation input to delete a translation.
3. Click Save.
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Figure 10: Translating entries
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Entering a list of permitted values

If you have the option to set a list of permitted values for a column, the input field
looks like this:

« If there is no defined list, enter the value in the simple input field that appears.

o If there is a defined list, select the value from the selection list that appears.
Figure 11: Selecting from a list of permitted values
Form ofaddress w

M
M5

The control on the default forms in the Manager is only available for the predefined
columns and for the user-defined columns (generally Spare field no. 01-Spare
field no. 10).

Entering multiple values

If a column is suitable for entering multiple values, you will see extra icons next to the
input field.
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Figure 12: Entering multiple values
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Table 21: Icons for entering multiple properties

Icon Meaning
Insert data. A separate input form opens.
8 Delete data.

Setting values

Use the slider to set a value within a defined range. The value appears next to the slider
and can be displayed in full with the tooltip. The color indicates how critical the value is
assessed to be.

Figure 13: Slider
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Entering scripts

This input field is used in the editors when the input data needs to have a specified
syntax (for example SQL, XML, or VB.Net). It has an advanced edit mode that provides
additional actions.

To switch to advanced mode

o Press Ctrl + Alt + Enter or click the button at the bottom right.

Figure 14: Directly entering a database query
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Table 22: Meaning of icon in advanced edit mode

Icon Meaning

B Quits advanced edit mode.

p>) Undoes last change.

¢ Redoes last change.

ob Cuts selected code.

Copies selected code into clipboard.
i Inserts code from clipboard.

1] Deletes selected code.

= Decreases insert.

= Increases insert.

E) Automatic text formatting.

E Formats text selection automatically.
i Shows/hides line numbers.

Inserts comments.

&
Il

Removes comments.

5] Inserts or removes line numbers.

= Inserts or removes automatic line breaks.
pl Shows or hides spaces and tabs.

Q Searches within code.

1 Inserts code snippet.

= Shows list of objects properties.

AL Shows auto completion list.

=] Shows list with parameter information.

1@l Shows additional information.

Table 23: Shortcut for editing scripts

Shortcut Description
Ctrl + C Copy to clipboard.
Ctl + Ins Copy to clipboard.
Ctrl + X Cut and copy to clipboard.
X One Identity Manager 8.2 User Guide for One Identity Manager Tools
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Shortcut

Description

Shift + Del

Ctrl + L

Ctrl + VvV

Shift + Ins

Ctrl +Y

Ctrl + Shift + Z
Ctrl + Z
Backspace

Shift + Backspace
Ctrl + Backspace
Del

Ctrl + Shift + L
Ctrl + Del

Data

Shift + Return.
Ctrl + Return

Ctrl + Shift + Return
Ctrl + Space

Ctrl + Space + Space
Tab

Shift + Tab

Ctrl + U

Ctrl + Shift + U
Ins

Ctrl + T

Ctrl + Shift + T
Shift + Alt + T

Alt + PgUp

Alt + PgDn

(GNE IDENTITY
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Cut and copy to clipboard.

Cut row and copy to clipboard.

Paste from clipboard.

Paste from clipboard.

Redo action.

Redo action.

Undo action.

Remove character behind cursor.
Remove character behind cursor.
Remove word behind cursor.

Delete character in front of cursor.
Delete row.

Delete to end of next word.

Insert line break.

Insert soft line break.

Insert row above.

Insert row below.

Auto-complete.

Show list with parameter information.
Insert indent/tab.

Remove indent/tab.

Change marked characters to lowercase.
Change marked characters to uppercase.
Toggle insert mode.

Swap characters in front and behind cursor.
Swap words in front and behind cursor.
Swap row with previous row.

Move row up.

Move row down.
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Shortcut

Description

PgUp

PgDn

Left arrow

Right arrow

Ctrl + Left arrow
Ctrl + Right arrow
Home

End

Ctrl + Home

Ctrl + End

PgDn

PgUp

Ctrl + PgUp

Ctrl + PgDn

Ctrl + ]

Ctrl + Down arrow
Ctrl + Up arrow
Ctrl + F

F3

Ctrl + F3

Shift + F3

Ctrl + Shift + F3
Ctrl + H

Ctrl +1

Ctrl + Shift + 1
Ctrl + Shift + Num-
Ctrl + Shift + Num+
Esc

Shift + Down arrow

(GNE IDENTITY
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Move up

Move down.

Move left.

Move right.

Move to previous word.
Move to next word.
Move to start of line.
Move to end of line.
Move to start of script.
Move to end of script.
Move up a page.

Move down a page.
Move to visible start.

Move to visible end.

Move to next bracket. (not possible on German keyboard)

Scroll down.

Scroll up

Open search dialog.

Search next.

Search forward.

Search backward.

Find previous.

Replace.

Search forward incrementally.
Search backward incrementally.
Reduce code block selection.
Extend code block selection.
Remove selection.

Extend selection down.
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Shortcut

Description

Shift + Up arrow

Shift + Left arrow

Shift + Right arrow

Ctrl + Shift + Left arrow
Ctrl + Shift + Right arrow
Shift + Home

Shift + End

Shift + Alt + Home

Ctrl + Shift + End

Shift + PgUp

Shift + PgDn

Ctrl + Shift + PgUp

Ctrl + Shift + PgDn

Ctrl + A

Ctrl + Shift + W

Ctrl + Shift + ]

Shift + Alt + Down arrow
Shift + Alt + Up arrow
Shift + Alt + Left arrow
Shift + Alt + Right arrow

Ctrl + Shift + Alt + Left
arrow

Ctrl + Shift + Alt + Right
arrow

Ctrl + mouse wheel

Extend selection up.

Extend selection left.

Extend selection right.

Extend selection to previous word.
Extend selection to next word.
Extend selection to start of line.
Extend selection to end of line.
Extend selection to start of script.
Extend selection to end of script.
Extend selection by one page up.
Extend selection by one page down.
Extend selection to visible start.
Extend selection to visible end.
Select all.

Select word.

Select up to the next bracket. (not possible on German
keyboard)

Extend selected block down.
Extend selected block up.
Extend selected block left.
Extend selected block right.

Extend selected block by one word to the left.

Extend selected block by one word to the right.

Adjust text size.

There is additional help provided for creating script code.

Syntax highlighting
The input fields support syntax highlighting depending on the syntax type.
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Auto-completion

You can use auto-completion when you write script code. The amount of scripted code to
enter is reduced by displaying the names of properties or functions that can be used. To
use auto-completion, use the shortcut Ctrl + SPACE in the relevant positions within the
input fields. The contents of the list is determined by the key words in the code.

Entering code snippets

One Identity Manager provides code snippets for you to use as templates. You can insert
code snippets using the following options:

1. Using the *1icon
a. Select the ™7 icon.
b. Select the code snippet.
2. Using a shortcut
a. Press F2.
b. Select the code snippet.
3. Using an aliases
a. Enter an alias.
b. Use Tab to insert the code snippet.

| NOTE: Be aware of case sensitivity when you enter the alias.

tion and the shortcut name are displayed in a tooltip.

Inputting values using dollar ($) notation

In input fields where a VB.NET term is expected, a help list opens when you enter $. All
properties of the current object are displayed. You can also see a tooltip with a detailed
description of the property. When you select a foreign key (FK) column, you can navigate
to the columns in the relevant table using the arrow keys. To end the selection in the target
column, press Enter or double-click. The complete $ notation for your selection should now
be shown in the input column. To close the help list without copying any data, press Esc or
leave the input field.

Figure 15: Help list for dollar notation
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Table 24: Meaning of icons used in the help list for dollar notation.

Icon Meaning

iIE Property of current object.
1 f Primary key (PK).

=§ Foreign key (FK).

oq Dynamic foreign key

(2 Table

V] Special properties

> Script

Table 25: Help list functions for dollar notation

Shortcut Action

Arrow down key Opens the help list.

Arrow up key, arrow down Navigate to previous or next entry.

key

Arrow left key, arrow right Navigate to the object above or below over the foreign
key key.

Data Accepts the value in dollar notation.

Entering database queries

It is sometimes necessary to enter database queries. You can enter the database queries
as a SQL query directly or compile the database queries with a wizard. Use the %, & or 6#
buttons to switch to the appropriate view.

Table 26: Meaning of the icons

Icon Meaning

B Enter a database query as a SQL query.
RN WHERE clause wizard.

& Filter designer.

Detailed information about this topic

« Wizard for entering database queries on page 44

o Filter designer on page 45
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Wizard for entering database queries

The wizard helps you to formulate a condition (where clause) for database queries. The
complete database query is composed internally. It always refers to the database table,

which is preset when the Where clause wizard starts.

Figure 16: WHERE clause wizard.
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There are predefined operators to make it easier to create conditions. The operators are
underlined. Operators with a help entry for the permitted value (such as column selection,

data input or free text) are shown in parentheses (< <Operator>>).

To create a database query using the WHERE clause wizard

1. Start the WHERE clause wizard with the *. button.

2. Create the database query.

When you hover over an operator, the cursor changes to a hand symbol.

If an operator has only two permitted values you can click to switch between
the values.

Click an operator with more than two permissible values to open a menu listing
the permissible operator values.

Click to select the required entry and then use the button to confirm the
selection.

-OR -
Double-click an entry to select the value.

A selection window opens in which you can select all database columns of the
base object and its related objects. Use SQL name to switch between the
display name and the technical name of tables and columns.
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« For complex database queries, you have the option of linking several
conditions together. After each condition there is a row showing the logical
operator for the connection, followed by another row for the next condition.
Use the button in front of a condition to delete it from the query.

« Use the Expert view button to switch to direct entry of the query in SQL
syntax. Use the Wizard view button to switch back to the simple input mode.

3. Click Continue.

The preview shows all the entries that meet the defined condition.
4. Click Continue.

The database query condition is shown in SQL syntax.
5. Click Finished.

Filter designer
The filter designer helps you formulate a condition for database queries. The complete

database query is composed internally. The database query always references the
Person table.

Figure 17: Filter designer

An employee is assigned to a dynamic role when he or she meets all of the o
following conditions:
For the entitlement with target system type |*| Active Directory |*| in the domain AEDoku-DE |~ + x o

, the following applies: Has permissions control |=|  Standard User (Profiles) |-

To create a database query using the filter designer

1. Start the wizard by pressing 5.

2. Using the all operator, specify whether at least one or all of the conditions defined
below must be fulfilled.

« When you hover over the operator, the cursor changes to a hand symbol.
« By clicking the operator, switch between the all and at least one values.
3. Create the conditions.
a. Inthe first menu, specify the condition type.
Depending on the condition type, other menus are displayed.

Table 27: Permitted condition types
Condition Type Meaning

Property Employee object properties. The drop-down menu with
permitted properties is already restricted to the most
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Condition Type Meaning

important employee properties.

For the account Employee’s user account. Valid user account properties

with the target depend on which target system is selected.
system type

Namespace and for which the Display in the filter
designer option is enabled.

For entitlements Employee target system group. Valid group properties

with the target depend on which target system is selected.
system type

Namespace and for which the Display in the filter
designer option is enabled.

SQL Query Free choice of SQL query (WHERE clause). To use the
WHERE clause wizard, click *.

b. From the additional menus, select the object attributes for the condition.

You can only select columns that are shown in the Unified

You can only select columns that are shown in the Unified

All other controls are operators and properties that you require to formulate

the condition. You can only select one entry from the drop-down menu. You can
select more entries from extended drop-down menus, where the properties are
displayed hierarchically and then added to the condition using an "or" operator.
You may enter text directly into input fields. Pop-up menus and input fields are

shown and hidden dynamically.

c. To insert another condition, click +. All partial conditions are linked by

an AND link.
d. To delete a condition, click %.

e. To the preview window, click @. All objects determined by the condition

are displayed.

Entering custom filter conditions

At certain points you can define custom filter conditions. The filter conditions are
formulated like a condition (WHERE clause) for a database query.

You can enter database queries directly or put them together with a wizard. Use the & and
"\, buttons to switch to the relevant view.

The comparison operators =, <>, <, >, <=, >=, and like are supported for defining
conditions.

To link condition you can use the logical operators AND, OR, and NOT.
You can use variables in your condition definitions. Variable must be masked.

Syntax: '$<variable>$'’
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the ®¥ button.

Example: '300 $$' compared to the value '300 $'

NOTE: If the condition contains a dollar sign, which is not labeling a variable, it
must be masked with $.

TIP: If you enter a condition directly, you can access predefined variables with

Each condition is displayed in a special control in the wizard. The controls contain
connection points to logically join single conditions or delete single conditions. The
connection points are set if you mouse over the edge of the respective control.

Figure 18: Wizard for entering filters
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To create a filter with a wizard

1. Click Create condition.
This inserts a control for the first condition.
2. Enter the condition.
a. Click the left-hand part of the condition and select the property to filter by.

The properties for filtering are listed in the menu. You can also define other
properties and use variables.

b. Specify the comparison operator. Click the comparison operator to change it.

The comparison operators =, <>, <, >, <=, >=, and like are supported for
defining conditions.

c. Specify the comparison value on the right-hand side of the condition.

You can enter a string for a comparison value or select a property from the list.
You can also use variables.

One Identity Manager 8.2 User Guide for One Identity Manager Tools
User Interface 47

(GNE IDENTITY

Quest
One Identity Manager tools user interface



NOTE: To switch back to the input field again, select Input field from
the menu.

3. To link condition you can use the logical operators AND, OR, and NOT.
a. Mouse over the edge of the control to which you wish to create a link.
The connection points appear.
b. Mouse over a connection point and select the connection.
This adds a new control for the next condition.

| NOTE: To remove a control, select the Delete connection point.

Selecting from lists

Use the menu to select an element.
| NOTE: You can add to some menus, in which case an entry selection appears in the list.

The extended menu links to elements from a different database table. To better display
your hierarchical structures, from this menu you can select from hierarchy trees as well as
flat structures.

Figure 19: Extended menus

Country | |V |
& O X
. R
Argertina (Argentina)

Australia (Australia)
Belgie (Belgium)

Brazil (Brazil)

Canada (Canada)
Darmark {Denmark)
Deutschland (Gemarny)

" aa "

To select a value form an extended menu

Open the menu by clicking the arrow.

2. Enable or disable an entry using a single click and close the menu.
- OR -
Enable or disable an entry by double-clicking.

The menu closes automatically.

TIP: As you enter text in the input field, the system filters the selection data for you.
When you open the menu you can see the entries that contain the text you entered. If the
entered text is unique, you can also select the relevant entry using the tab.
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To search in the menu

Click the magnifying glass in the menu title bar to open the search dialog.
Enter your search term.

Set the option Case sensitive if required.

Start the search with the Search or Enter button.

Use F3 to continue searching.

AL S

End the search with Esc.

Selecting a dynamic entry

Some foreign key relationships are identified dynamically in One Identity Manager. There
are two steps to selecting a dynamic foreign key.

1. Specify the table in which the object should be identified.

2. Select the actual object.

Figure 20: Selecting dynamic entries

Account manager Dokuwvilan/users/Bloggs Jan

e Table |ADSAccount v|
Account manager |Doku.\ri.lan!users!BIoggsJan v|
Concel

To specify a dynamic entry:
1. Click = next to the field.
2. Under Table, select in the table in which to identify the object.
3. Select the actual object from the next list.
4. Click OK.

Setting a date

As well as manually entering a date, you can copy a date into the input field from the
control. Open the control using the [...] button beside a date input field.
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Figure 21: Control for setting a date

Entry date |9r4rzo14 |Z|

1 September 2014 L4

Mo Di Mi De Fr 5a So
25 26 27 28 29 30 H

The title bar of the control repeats the name of the corresponding input field.

To select a date:

1. Today's date is identified by a colored border. Click Today to select today's date.
- OR -
Select the date using the calendar.

a. Select the month and year using the arrow beside the Month year control or
click the Month year control.

b. Select the day by clicking in the calendar.
2. Click OK.

Editing login hours

This control is used, for example, to configure the daily login hours for a user account.

Figure 22: Login time control

B Assign  [] FRemove Reverse b (—“

The calendar shows a 7-day week, each box represents one hour. The configured login
times are shown in color, respectively. If a box is filled, login is allowed. If the box is
empty, login is denied.
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To specify login times
o Select a time period with the mouse or keyboard.
o Select Assign to enable login in the selected period.
. Select Remove to deny login in the selected period.
o Select Reverse to invert the selected period.

o Use the arrow keys to reset or repeat a selection.

Layout of object relations

This control element shows the relations between the One Identity Manager database
objects (Parent/ChildRelation).

« Only the assigned elements are displayed in the Remove assignments pane.
You can remove assigned elements here.

. Inthe Add assignments pane, you can see all the elements.
Make new assignments or remove existing ones here. If allowed, you can use a filter
to further restrict the selection of elements you want to show.

To activate or deactivate an assignment

o Use the control's context menu.
- OR -

o Double-click an entry.
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Figure 23: Displaying assignments in the control element

Remove assignments

Active Directory user accounts

@ Harris Clara

Add assignments

Active Directory user accounts
A AEDoku-DE
=i d6
Eﬁﬁ Doku
Elﬁ users

@ Harris Clara
Q Flaster Monika
ﬂ Just Annett
Q Just Cornelia
ﬂ Winter Sandra

BEloggs Jan

Summer Jan

Canonical name

Dokuwvilan/users/Harris Clara

Drescription

Table 28: Meaning of icons in the control element

Icon Meaning

@ Object is assigned to the selected base object.

Object is not assigned to an object.

v} Object is assigned to another object.

| NOTE: In the list, assigned elements come before unassigned elements.

Table 29: Control element context menu items

Entry Meaning
Assign Assign object to the selected base object.
Remove Remove assignment of object to base object.
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Entry

Meaning

Assign child objects

Remove child objects

Assign all objects
Remove all assignments
Search

Go to object

Go to assigned object

Show objects already

assigned to other objects.

Hide objects already

assigned to other objects.

In a hierarchical structure, assign the selected object and its
child objects to the base object.

In a hierarchical structure, remove the assignments of the
selected object and its child object to the base object.

Assign all existing objects to the base object.
Remove all assignments to the base object.
Opens the search dialog.

Go to the selected object.

Go to this object's assigned base object.

Objects that are assigned to other objects are shown in the
Add assignments pane.

Objects that are assigned to other objects are hidden in the
Add assignments pane.

Displaying assignments

The membership tree shows the direct and indirect assignments to a base object. It also
shows the source of the indirectly assigned objects. This means that the object was
assigned to a base object through a dynamic role, for example, or through inheritance.

« Only the assigned elements are displayed in the Remove assignments pane. You
can remove the assignments here.

« Under Add assignments you can see all the elements.

Make new assignments or remove existing ones here. If allowed, you can use a filter
to further restrict the selection of elements you want to show.

NOTE: Objects marked for deletion and outstanding objects are struck through on the

overview form.

To activate or deactivate an assignment

o Use the control's context menu.

-0OR -

o Double-click an entry.
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Figure 24: Displaying assignments
Remove assignments

Active Directory user account == 22 (&) Canonical name
@ Eloggs Jlan Doku.wvilan/users/Blogags Jan
\f Harris Clara @ Doku.wvilan/users/Harris Clara

Add assignments

Active Directory user account == 22 (&) Description
Elﬁﬁ Doku
EIE users

@ Eloggs Jlan
\f Harris Clara @

Flaster Monika

Just Annett

Just Cornelia

summer Jan

Winter Sandra

Table 30: Meaning of icons in the membership tree

Icon Meaning

) Object is assigned directly to the selected base object.

v} Object is assigned indirectly to the selected base object.

% Object is assigned directly and indirectly to the selected base object.
Object is not assigned to a base object.
Inheritance interruption. Only when objects are assigned in hierarchical struc-
tures.

+ Indirect assignment.

= Assignment through dynamic roles.

@ Assignment not yet effective. The DBQueue Processor has not yet calculated the
assignment.

The change in value is planned for a specific date and time.
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| NOTE: The list displays assigned elements before unassigned elements.

Table 31: Entries in the membership tree context menu

Entry Meaning
Assign Directly assign the selected object to the base object.
Remove Remove the assignment of the selected object to the base object.

Assign child In a hierarchical structure, assign the selected object and its child objects
objects to the base object.

Remove In a hierarchical structure, remove the assignments of the selected object
child objects and its child object to the base object.

Assign all Directly assign all existing objects to the base object.

objects

Remove all Remove all direct assignments to the base object.
assignments

Search Opens the search dialog.
Go to object Go to the selected object.

Extended Switches to the detailed form for the selected object, where you can make
properties additional assignments. A prerequisite for this is that the selected object is
assigned and this assignment has been saved.

NOTE: Use the Search function to search the entire assignment tree for the occurrence
of specific texts. The search sequence does not follow the displayed hierarchical
structure of the tree, but instead the internal structures of the control element. As such,
the search seems to jump through the tree at random. All records are searched to find
the requested object.

General control key combinations

Table 32: General control key combinations

Shortcut Action

Tab, shift + tab, left arrow key, right arrow key, down Move within the controls.
arrow, up arrow

Down arrow, up arrow, page down key, page up key, Move in lists and in hierarchical

home, end structures.
<+> or right arrow key Open hierarchy level.
<-> or left arrow key Close hierarchy level.
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Shortcut Action

Space or Enter Select an entry.

Shift + Return. Select multiple entries.

F4 or Alt + down arrow Open selection list.

Del Remove entry from the list.

Manager program settings

General configuration settings are specified in the Manager.exe.config configuration file.
Valid global configuration settings can also be defined through the global configuration file
Global.cfg in One Identity Manager's own format. The configuration files are stored in the
program directory. For more information, see the One Identity Manager Process Monitoring
and Troubleshooting Guide.

To change the program settings in the Manager

o Inthe Manager, select the Database > Settings menu item.

Detailed information about this topic

« User settings in the Manager on page 56
« Special settings for individual program components in the Manager on page 58
« General program settings in the Manager on page 59

« Plugins available in the Manager on page 59

User settings in the Manager

On the User tab, configure your user-specific program settings. These settings are stored
in the One Identity Manager database user configuration.

General

« Show balloon tips: Specifies whether speech bubbles, which provide information
about program functionality, are shown in the program.

. Show large images in navigation panes: Specifies whether smaller or larger
icons are displayed on the categories.

. Show additional icons: Specifies whether icons are shown in the task list in
addition to the descriptions.
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. Use single clicks: Specifies whether objects are loaded with a single click or by
double-clicking.

. Use technical display values: Specifies whether display names or technical
names are used when collating data exports.

Behavior

. Enable quick edit mode: Specifies whether quick editing is enabled.

By default, an object's overview form is displayed first. You can, however, configure
the program to show the edit form for the object first, which allows faster editing. In
order to do this quick edit mode has to be enabled. Quick edit mode is indicated by an
additional icon in the program’s status bar.

. Enable expert mode: Specifies whether expert mode is used. Setting this option
switches the program from standard view mode to advanced mode.

. Enable list limit: Specifies whether the number of elements shown in the result list
and list items in controls should be limited.

If this option is enabled, the number of elements must be entered. To do this,
you can choose between the global system settings or the local, personal setting
for the user.

« Use system settings: Specifies whether the system settings should be used for the
list limit.
If this option is activated, then the global system settings from the Common |
DBConnection | ListLimit parameter is used. If the number of results is greater
than the defined number, a filter dialog opens.

. Objects: Personal setting for the object list limit. If the number of results is greater
than the defined number, a filter dialog opens.

Usage

o Form history length: Number of forms available to browse through in the form
history. You find the form history in the menus attached to the <Back> and
<Forward> buttons in the main toolbar.

. Show recently used objects: Specify whether or not the most recently used
objects are displayed. If this option is set, the objects used last are shown in a
separate node in the result list.

« Object type count: This number specifies how many objects per object type are
shown per menu entry when the option Show recently used objects is enabled.

After starting

« Visible root nodes: The number of categories to be displayed initially in the
navigation view. Changes become effective after a restart.

One Identity Manager 8.2 User Guide for One Identity Manager Tools

@NE IDENTITY User Interface 57

Quest
One Identity Manager tools user interface



Related topics

« Manager program settings on page 56
« Layout mode in the Manager on page 20

« Limiting list entries using the list limit on page 61

Special settings for individual program
components in the Manager

On the Features tab, you can create special program settings for individual program
components. The settings are stored in the One Identity Manager database user account
configuration.

Simple search

. Default search operator: Search operator to be used by default for simple
searches. Permitted values are starts with, contains or equals.

Process information

The settings in the Process information area relate to the process view and are visible
only when this functionality has been activated. For detailed information about the
evaluation of process information, see the One Identity Manager Operational Guide.

. Display complexity: Set the display range. Permitted values are:
o Activities: Activity information (top hierarchy level) is shown.
. Details: Information about activities and their details is shown.

. Single steps: Information about activities, details, and individual steps at the
selected depth is shown.

o Single step details: Set the depth of detailed information shown for individual
steps. Permitted values are:

. Basic information: Individual steps with a detail depth of basic
information are shown.

. Extended information: Single steps with a detail depth of basic
information and extended information are shown.

. Complete information: Single steps with a detail depth of Basic
information, Supplementary information, and Complete information
are shown (technical view).

« Show whole tree: If this option is activated, the entire hierarchy tree automatically
opens when the process view is loading. If this option is deactivated, the hierarchy
tree is not opened when the process view is loaded.
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. Show selected process automatically: If this option is activated, the entire
hierarchy tree automatically opened when a process is selected. If this option is
deactivated, the hierarchy tree is not opened when a process is selected.

Related topics

« Manager program settings on page 56

General program settings in the Manager

On the Program tab, enter the common program settings. These settings are saved in the
registry database on the workstation.

Language settings
. Language: Language used for formatting data, such as date formats, time formats,
and number formats.

. Other user interface language:Language for the user interface. The initial
program login uses the system language for the user interface. Changes to the
language settings take effect after the program has been restarted.The language is
set globally for all One Identity Manager programs, which means the language
setting does not have to be configured for each program individually.

Miscellaneous

o Clear local cache: Click the button to empty the local cache directory
%LocalAppData%\One Identity\One Identity Manager\Cache.

« Show additional navigation information: If this option is activated, additional
information is shown for individual interface components.

NOTE: The option is not saved permanently. It has to be reset each time the
program is started.

Related topics

« Manager program settings on page 56

« Detailed information about the user interface on page 60

Plugins available in the Manager

The Plugins tab shows the available program plugins with a short description of
their features.

One Identity Manager 8.2 User Guide for One Identity Manager Tools

(GNE IDENTITY User Interface | 59

Quest
One Identity Manager tools user interface



To enable or disable a plugin in the Manager
« Double-click the plugin name.

| NOTE: You can choose more plugins in the Manager menu by clicking Plugins.

Related topics

- Manager program settings on page 56

Reloading changes to the user interface

In the status bar, the & icon indicates that the user interface was modified.

To reload modifications to the system data

In the status bar, double-click the icon &.

2. Enable the Restore user interface option. After loading the modifications, the
system then navigates back to the point in the interface that you were
previously using.

3. Click Yes.

Detailed information about the user
interface

You will usually need to display more information about individual interface elements, such
as menu entries or forms, only if the program's user interface is edited.

To display detailed information

1. Select the Database > Settings menu item.
2. On the Program tab, enable the Show additional navigation information
option.
NOTE: The option is not saved permanently. It has to be reset when the
program is started.
The following information appears:
« Manager shows the form name in the status bar. It displays in the following format:
<logical form> [(<physical form>)]

| TIP: Double-click the form name to copy the name to the clipboard.
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« Inthe Manager, the Show system data entry is displayed in the menu bar in the
View menu. This opens a form that lists detailed information about the loaded menu
items, forms, and form definitions.

« Inthe Manager, in expert mode, the Definition context menu entry is displayed in
addition in the navigation view. This shows advanced technical information about
configuring a menu item.

o If menu entries or tasks are linked to preprocessor-relevant configuration
parameters, the preprocessor conditions are shown behind the menu items and
tasks.

Related topics

« Expert mode in the Manager on page 20

« Manager program settings on page 56

Limiting list entries using the list limit

Table 33: Configuration parameter for limiting results

Configuration Effect
parameter

Common | DBCon-  This configuration parameter specifies the number of list entries
nection | ListLimit above which the filter request becomes effective

Common | DBCon-  This configuration parameter specifies the number of list entries
nection | above which the filter request in the web front becomes effective.
WeblListLimit

You can use a list limit to limit the number of elements displayed in a result list and in the
control elements with list values (for example, menus). If the number of results exceeds
the limit, a filter dialog opens.

In the Designer, you can globally define the maximum number of entries displayed before
the filter dialog is opened in the Common | DBConnection | ListLimit configuration
parameter. In addition, the current user can use the system setting or enter their own
limit. The personal limit overwrites the global value in the configuration parameter.

To use the system settings

1. Select the Database > Settings menu item.

2. On the User tab in the Behavior pane, enable the Enable list limit and Use
system settings options.

This setting applies the global value defined in the Common | DBConnection |
ListLimit configuration parameter.
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To use a personal limit

Select the Database > Settings menu item.
On the User tab in the Behavior pane, enable the Enable list limit.

On the User tab in the Behavior pane, disable the Use system settings option and
enter the number of objects in Objects.

Related topics

« Limiting list sizes using simple filters on page 62
« User-defined filters in the Manager on page 64
« Searching for list entries on page 63

« Database search in the Manager on page 70

Limiting list sizes using simple filters

You can use the filter dialog to limit the entries in a list though defined filter criteria. A filter
remains in use until you reset it. Settings in the filter dialog are saved in the user
configuration.

If you want to start certain search queries more frequently, create search queries for the
advanced database search or create user-defined filters.

To limit a result set

1. In Filter condition, enter the text to use as a basis for filtering. Use of * as wild
cards is permitted. Case sensitivity is not taken into account.

In Apply to, enable the properties to which the filter condition is to be applied.

If you only want lists to show objects that meet the filter condition and are already
assigned to the base object, enable the Only show current assignment option.

| NOTE: This option is only available for lists with object assignments.
4. Click Apply.

NOTE: To display all objects, click Show all. The filter condition is not applied
in this case.

Example:

This filter condition is used to search for all parts of an employee’s full name. This is
put together in the following manner:

Full name
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Last name, first name
Example:

Miller, Max

Miller-Mayer, Max

Macmiller, Max

Filter Description Find, according to
condition example

Miller or Finds all employees whose full name contains Miller, Max

*Miller* the string Miller.

Miller-Mayer, Max

Macmiller, Max

Miller* Finds all employees whose full name begins Miller, Max

with the Miller. Miller-Mayer, Max

*Miller Finds all employees whose full name ends No entry
with the Miller.

Related topics

« Limiting list entries using the list limit on page 61
« Searching for list entries on page 63
« User-defined filters in the Manager on page 64

« Database search in the Manager on page 70

Searching for list entries

Use the search dialog to search for entries within a list.

To search in a list

1. Open the search dialog from the Search context menu, by clicking the @ icon or with
the shortcut Ctrl + F.

2. Enter the Search term or select a previous one from the list using the arrow button.
3. Setthe Case sensitive option if required.
4. Start the search with the Search or Enter button.
5. Use F3 to continue searching.
6. End the search with Esc.
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Table 34: Shortcuts for the search dialog box

Shortcut Action

Ctrl + F Open search dialog.
Data Start search.

Esc End search.

F3 Search next.

For a wider ranging search, use the database search function.

Related topics

Database search in the Manager on page 70

User-defined filters in the Manager

You make use of user-defined filters if you wish to run specific search queries frequently.
You can create your own (private) filters or public filters.

User-defined filters allow you to run the following searches:

Searching for a search term with placeholders within the display values of the
selected object definition

Searching entries with a SQL condition

Searching for a search term across all columns of an object definition that are
indexed for the full-text search

Detailed information about this topic

Creating filter queries using wildcards in the Manager on page 65
Creating filter queries in the Manager using SQL conditions on page 66
Creating filter queries using full-text search in the Manager on page 67
Applying filters in the Manager on page 68

Publishing filters in the Manager on page 68

Exporting and importing filters in the Manager on page 68

Attaching filters in the Manager on page 69

Editing filters in the Manager on page 70

One Identity Manager 8.2 User Guide for One Identity Manager Tools

(GNE IDENTITY User Interface

by Quest
One Identity Manager tools user interface

64



Creating filter queries using wildcards in
the Manager

A search query using placeholders searches for the search pattern in the display values of
the selected object definition.

To create a filter query using placeholders in the Manager

1. Inthe Manager, select the My One Identity Manager > Filters category.
2. Select the New filter context menu item.
3. Inthe Define a filter dialog, select the Wildcard filter method.
4. Inthe Filter parameter pane, enter the following information.
« Filter objects of: Select the object definition in which to perform the search.

o Search pattern: Enter the search pattern. You can use * as a wildcard in the
search pattern.

Examples:

Pattern* - searches for all entries whose display value starts with the
Pattern string

*Pattern - searches for all entries whose display value ends with the
Pattern string

*Pattern* - searches for all entries whose display value contains the
Pattern string

Pattern - searches for all entries whose display value matches the
Pattern string

5. (Optional) If required, specify the following settings in the Optional
parameter pane.

. Sort criteria: Specify the properties (columns) by which to sort the search
result. Click ™ to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.

. Display template: Specify the format in which the results are displayed.
Click "\ to show all available properties according to the object definition. Click
on a name to transfer the entry to the input field.

In the Save filter section, enter a name and description for the search filter.
(Optional) To make the filer available to all users

a. Click Publish.

b. Confirm the security prompt with Yes.

8. To save the filter, click Save.
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Related topics

« Creating filter queries in the Manager using SQL conditions on page 66
« Creating filter queries using full-text search in the Manager on page 67

« Publishing filters in the Manager on page 68

Creating filter queries in the Manager using
SQL conditions

A search query with an SQL condition searches all entries of the selected object definition
that match the SQL condition.

To create a filter query using a SQL condition in the Manager

1. Inthe Manager, select the My One Identity Manager > Filters category.
2. Select the New filter context menu item.
3. Inthe Define a filter dialog, select the SQL filter method.
4. Inthe Filter parameter pane, enter the following information.
. Filter objects of: Select the object definition in which to perform the search.

« Search pattern: Enter the condition. Enter the condition as a valid database
query WHERE clause. You can enter the database queries as an SQL query
directly or compile the database queries with a wizard. Use the Expert view
or Simple view button to switch to the appropriate view.

5. (Optional) If required, specify the following settings in the Optional
parameter section.

« Sort criteria: Specify the properties (columns) by which to sort the search
result. Click ™ to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.

. Display template: Specify the format in which the results are displayed.
Click "\ to show all available properties according to the object definition. Click
on a name to transfer the entry to the input field.

6. Inthe Save filter section, enter a name and description for the search filter.
7. (Optional) To make the filer available to all users

a. Click Publish.

b. Confirm the security prompt with Yes.

8. To save the filter, click Save.

Related topics

« Creating filter queries using wildcards in the Manager on page 65

« Creating filter queries using full-text search in the Manager on page 67
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« Publishing filters in the Manager on page 68

Creating filter queries using full-text search
in the Manager

NOTE: To use the full-text search, you must run the program over an application server
with an installed search service. For detailed information about installing an application
server for full text search, see the One Identity Manager Installation Guide.

A search query using full-text search, searches for the specified search term in all columns
of the selected object definition that are indexed for full-text search. For detailed
information about configuring columns for the full text search, see the One Identity
Manager Configuration Guide.

To create a filter query in the Manager using the full-text search

1. Inthe Manager, select the My One Identity Manager > Filters category.
2. Select the New filter context menu item.
3. Inthe Define a filter dialog, select the Full text filter method.
4. Inthe Filter parameter pane, enter the following information.
. Filter objects of: Select the object definition in which to perform the search.

. Search string: Enter the search term. The use of wild cards is permitted. For
examples, refer to Rules and examples for the full-text search on page 75.

5. (Optional) If required, specify the following settings in the Optional
parameter section.

o Sort criteria: Specify the properties (columns) by which to sort the search
result. Click ™ to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.

. Display template: Specify the format in which the results are displayed.
Click ™\ to show all available properties according to the object definition. Click
on a name to transfer the entry to the input field.

6. Inthe Save filter section, enter a name and description for the search filter.
7. (Optional) To make the filer available to all users

a. Click Publish.

b. Confirm the security prompt with Yes.

8. To save the filter, click Save.

Related topics

« Creating filter queries using wildcards in the Manager on page 65

« Creating filter queries in the Manager using SQL conditions on page 66
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« Publishing filters in the Manager on page 68

Applying filters in the Manager

To use a filter in the Manager

« In the Manager, select the filter in the My One Identity Manager >
Filters category.

Related topics

« Advanced database search on page 72

Publishing filters in the Manager

NOTE: To create, edit, and delete public filters, the user requires the Option to define,

modify, and delete public filters. program function. (Common_PublicFilterDefine).
You can make filters available to all users by publishing them. You have the option to
publish a filter when you create it. Afterward, you can also publish a private filter.

To publish a filter in the Manager

1. In the Manager, select the filter in the My One Identity Manager >
Filters category.

Select the Edit filter context menu item.
Click Publish.

Confirm the security prompt with Yes.
Click Save.

A N

Related topics

« Creating filter queries using wildcards in the Manager on page 65
« Creating filter queries in the Manager using SQL conditions on page 66
« Creating filter queries using full-text search in the Manager on page 67

« Exporting and importing filters in the Manager on page 68

Exporting and importing filters in the
Manager

To make custom filters available to other users, you can export and import them.
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To export a filter in the Manager

1. In the Manager, select the filter in the My One Identity Manager >
Filters category.

Start the export using the Export filter context menu.

. Using the file browser, select the directory path for the report and enter a file name
for the filter.

4. Click Save.
The filter file (*.xml) is generated.

To import a filter in the Manager

In the Manager, select the My One Identity Manager > Filters category.
Start the export using the Import filter context menu.

Select the filter file from the file browser.

Click Open.

LN

Related topics

« Attaching filters in the Manager on page 69
« Publishing filters in the Manager on page 68

Attaching filters in the Manager

You can attach filters to various categories so you can quickly access the filtered objects.

To attach a filter in the Manager

1. In the Manager, select the filter in the My One Identity Manager >
Filters category.

2. Select the Attach context menu.

3. Select one or multiple menu categories to attach the filter to.

When you select a category with an attached filter in the navigation view, all objects that
correspond to the filter are displayed on a separate form page. The following functions
are available:

« Double-click an entry on this form page to switch to the corresponding object. The
first available form is opened.

« Open the export form using the Export data task or click Export data on the
context menu. The filter condition of the attached filter is already applied as an
export condition. For detailed information about exporting data, see the One Identity
Manager Operational Guide.
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Editing filters in the Manager

NOTE: To create, edit, and delete public filters, the user requires the Option to define,
modify, and delete public filters. program function. (Common_PublicFilterDefine).

To edit a filter in the Manager

1. In the Manager, select the filter in the My One Identity Manager >
Filters category.

2. Select the Edit filter context menu item.
Edit the filter settings in the Define a filter dialog.
Click Save.

Related topics

« Creating filter queries using wildcards in the Manager on page 65
« Creating filter queries in the Manager using SQL conditions on page 66

« Creating filter queries using full-text search in the Manager on page 67

Deleting filters in the Manager

NOTE: To create, edit, and delete public filters, the user requires the Option to define,
modify, and delete public filters. program function. (Common_PublicFilterDefine).

To delete a filter in the Manager

1. In the Manager, select the filter in the My One Identity Manager >
Filters category.

2. Select the Remove filter context menu item.

Database search in the Manager

In the Manager, you can run a simple database search or an advanced database search.
Run a simple database search once. You cannot save a simple database search. Use an
advanced database search if you wish to run specific search queries frequently. You can
save the search query.

Detailed information about this topic

« Simple database search on page 71

« Advanced database search on page 72
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Simple database search

The simple database search allows you to run the following searches:

« Searching for a search term with placeholders within the display values of the
selected object definition

« Searching for a search term across all columns of an object definition that are
indexed for the full-text search

Detailed information about this topic

« Running simple database searches using wildcards on page 71

« Running simple database searches using full-text search on page 72

Running simple database searches using
wildcards

A search query using placeholders searches for the search pattern in the display values of
the selected object definition.

To run a simple database search in the Manager with placeholders

1. Inthe Manager, select the View > Database search menu item.
The database search is displayed in the navigation view.
2. Enter the following information in the Search section.

a. Search in: Select the object definition. All object definitions in the currently
selected category are displayed.

b. Search text: Enter the search term. You can use * as a wildcard. Case
sensitivity is not taken into account.

Examples:

Pattern or pattern* - searches for all entries whose display value starts with
the Pattern string

*Pattern - searches for all entries whose display value ends with the
Pattern string

*Pattern* - searches for all entries whose display value contains the
Pattern string

c. Full-text search: Disable the option.

3. Start the search using the Search button.

| TIP: Press ¥ to set the current query as the default for future search queries.
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Related topics

« Running simple database searches using full-text search on page 72

Running simple database searches using full-
text search

NOTE: To use the full-text search, you must run the program over an application server
with an installed search service. For detailed information about installing an application
server for full text search, see the One Identity Manager Installation Guide.

A search query using full-text search, searches for the specified search term in all columns
of the selected object definition that are indexed for full-text search. For detailed
information about configuring columns for the full text search, see the One Identity
Manager Configuration Guide.

To run a simple database search in the Manager as a full-text search

1. Inthe Manager, select the View > Database search menu item.
The database search is displayed in the navigation view.
2. Enter the following information in the Search section.

a. Search in: Select the object definition. All object definitions in the currently
selected category are displayed.

b. Search text: Enter the search term. The use of wild cards is permitted. For
examples, refer to Rules and examples for the full-text search on page 75.

c. Full-text search: enable the option.

3. Start the search using the Search button.

| TIP: Press ¥ to set the current query as the default for future search queries.

Related topics

« Running simple database searches using wildcards on page 71

Advanced database search

The advanced database search allows you to run the following searches:

« Searching for a search term with placeholders within the display values of the
selected object definition

« Searching entries with a SQL condition

« Searching for a search term across all columns of an object definition that are
indexed for the full-text search
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TIP: The saved search queries are displayed in the Manager in the My One Identity
Manager > Filters category. You can run or edit the search queries there or export
them for other users.

Detailed information about this topic

« Creating search queries using wildcards on page 73

« Creating search queries using SQL conditions on page 74
« Creating search queries using full-text search on page 75
« Running advanced database searches on page 77

« User-defined filters in the Manager on page 64

Creating search queries using wildcards

A search query using wildcards searches for the search pattern in the display values of the
selected object definition.

To create a filter query using wildcards in the Manager

1. Inthe Manager, select the View > Database search menu item.
The database search is displayed in the navigation view.

2. To open the advanced database search, click the Advanced button in the
Search section.

3. Click New search and select the Wildcard search method.
In the Search parameter pane, enter the following information.
« Search in: Select the object definition in which to perform the search.

o Search pattern: Enter the search pattern. You can use * as a wildcard in the
search pattern.

Examples:

Pattern* - searches for all entries whose display value starts with the
Pattern string

*Pattern - searches for all entries whose display value ends with the
Pattern string

*Pattern* - searches for all entries whose display value contains the
Pattern string

Pattern - searches for all entries whose display value matches the
Pattern string

5. (Optional) If required, specify the following settings in the Optional
parameter pane.
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. Sort criteria: Specify the properties (columns) by which to sort the search
result. Click "\ to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.

. Display template: Specify the format in which the results are displayed.
Click *\ to show all available properties according to the object definition. Click
on a name to transfer the entry to the input field.

6. To save the search, enter a name and a description for the search filter in the Save

search pane and click Save.

Creating search queries using SQL conditions

A search query with an SQL condition searches all entries of the selected object definition
that match the SQL condition.

To create a filter query using an SQL condition in the Manager

1.

In the Manager, select the View > Database search menu item.
The database search is displayed in the navigation view.

To open the advanced database search, click the Advanced button in the
Search section.

Click New search and select the SQL search method.
In the Search parameter pane, enter the following information.
« Search in: Select the object definition in which to perform the search.

« Search pattern: Enter the condition. Enter the condition as a valid database
query WHERE clause. You can enter the database queries as an SQL query
directly or compile the database queries with a wizard. Use the Expert view
or Simple view button to switch to the appropriate view.

(Optional) If required, specify the following settings in the Optional
parameter section.

« Sort criteria: Specify the properties (columns) by which to sort the search
result. Click ™ to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.

. Display template: Specify the format in which the results are displayed.
Click ™\ to show all available properties according to the object definition. Click
on a name to transfer the entry to the input field.

To save the search, enter a name and a description for the search filter in the Save
search section and click Save.

One Identity Manager 8.2 User Guide for One Identity Manager Tools

@NE IDENTITY User Interface 74

Quest
One Identity Manager tools user interface



Creating search queries using full-text search

NOTE: To use the full-text search, you must run the program over an application server
with an installed search service. For detailed information about installing an application
server for full text search, see the One Identity Manager Installation Guide.

A search query using full-text search, searches for the specified search term in all columns
of the selected object definition that are indexed for full-text search. For detailed
information about configuring columns for the full text search, see the One Identity
Manager Configuration Guide.

To create a search query in the Manager using the full-text search

1. Inthe Manager, select the View > Database search menu item.
The database search is displayed in the navigation view.

2. To open the advanced database search, click the Advanced button in the
Search area.

3. Click New search and select the Full text search method.
4. Inthe Search parameter pane, enter the following information.
o Search in: Select the object definition in which to perform the search.

o Search string: Enter the search term. The use of wild cards is permitted. For
examples, refer to Rules and examples for the full-text search on page 75.

5. (Optional) If required, specify the following settings in the Optional
parameter area.

« Sort criteria: Specify the properties (columns) by which to sort the search
result. Click ™ to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.

. Display template: Specify the format in which the results are displayed.
Click * to show all available properties according to the object definition. Click
on a name to transfer the entry to the input field.

6. To save the search, enter a name and a description for the search filter in the Save
search area and click Save.

Rules and examples for the full-text search

Table 35: Rules with examples for searching

Example Description

John Doe Finds John Doe but not John Donut.

Search results must contain all of the separate terms in the query. A logical
AND is used.

John OR Finds Jane Doe and John Donut.
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Example Description

Doe Placing OR between the search terms, acts as a logical OR operator. The
result of this search contain at least one of the two search terms.

John NOT Finds John but not John Doe.

Doe The results of this search do not contain the term that comes after NOT.
J* Finds John and Joanna.
The * functions as a wildcard for any number of characters to complete the
term.
Do? Finds Doe but not Donut.
The ? functions as a wildcard for a single character to complete the term.
"John Provides results in which the search terms John and Doe follow one another.
Doe” Results of this search contain the string in quotes as phrase.
John Finds Jon Does but also other similar results. A tilde ~ after the search term
Doe~ indicates that the search should also find similar results. The means that

incorrectly spelled terms can be found as well.

You can specify the level of similarity by adding a number between 0 and 1
(with decimal point) after the tilde ~. The higher the number, the more
similar the results.

During the search, the search strings are broken down into tokens by the search index in
use. The search terms are compared with these tokens.

Use the Common | Indexing | IndexNonTokenChars configuration parameter to
specify which delimiters are to be used. The configuration parameter can be extended if
certain characters in the search text have linking function.

If the Common | Indexing | IndexUselLegacyAnalyzer configuration parameter is
enabled, alternative tokenizing is performed also. The alternative method of tokenizing is
preferable for long tokens. For example, if the string Department_01 is a token, the
partial string Department is not considered to be a token.

The following tokens are named.

Table 36: Tokens for alternative tokenizing

Token Description with example

Words Sequence of letters and/or numbers

Enumeration Words linked by punctuation marks (_=/.,) of which at least every second
one contains a number.

An example is Department_01.

Sequences are also decimal numbers and IP addresses.

Email An email address is often made up of first name, last name, company
X One Identity Manager 8.2 User Guide for One Identity Manager Tools
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Token Description with example

addresses name and generic top-level domain (for example .com). The order or
spelling of the first and last names may vary (for example, use of
initials). The special character @ and the punctuation mark (.) not only
separate each part of the email address but also links them so that

Examples of email addresses are Ben.King@example.com and
C.Harris@example.com.

Host names For example website.example.com.
Acronym For example U. S. A.
Apostrophe For example O'Reilly.

@, & For example Me&you.
surrounded
by letters

Umlauts such For example Max Miiller.
as g, 6,0

NOTE: Changing the configuration parameter means rebuilding the search index, which
may take some time.

Running advanced database searches

To run an advanced database search in the Manager

1. Inthe Manager, select the View > Database search menu item.
The database search is displayed in the navigation view.

2. To open the advanced database search, click the Advanced button in the
Search section.

3. Double-click the search filter in the Saved filters area.

4. Start the search using the Search button.

TIP: The saved search queries are shown in the My One Identity Manager > Filters
category. You can run or edit the search queries there or export them for other users.

Related topics

« User-defined filters in the Manager on page 64
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Displaying extended properties for
objects

| NOTE: The Manager must be running in expert mode to show object properties.

To show extended object properties

« Select the object and open the Properties item in the context menu.

« On General, you can see the object's general properties, for example, ID,
status, or primary key.

TIP: The primary key can be copied in different formats. To do this, click the
Primary key or the Table relations caption.

« All the object columns are displayed in a grid on Properties with their values.
You can choose between a simple column view and the advanced view with
additional data for column definitions.

Individual properties can be highlighted with an icon.

To customize the display properties

« On the Properties tab, select the =/ Property pages icon and set the
required display properties.

« On the Permissions tab, based on the permissions groups, you see what
permissions apply to an object. The first entry shows the basic permissions for
the table. The permissions for this particular object are displayed beneath that.
The other entries show the column permissions.

TIP: Double-click the table entry, the object entry, or a column entry to
display the permissions group from which the permissions were determined.

Table 37: Icon used for permissions

Icon Meaning

ol Permissions exist.

. Permissions have been removed by the object layer

=

Permissions limited by conditions.

« You can see which change labels the object belongs to on the Change labels
tag. Here you can assign a new or an existing change label to the object and its
dependent objects. For more information about working with change labels,
see the One Identity Manager Operational Guide.

« On the Export tab, you can export the object in the One Identity Manager-
internal transfer format.
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Related topics

« Expert mode in the Manager on page 20

Multiple object edit in the Manager

It is possible to edit more than one object of the same object type at the same time in the
Manager. The form tab of the main data form shows the number of selected objects and the
object type. Input fields with different values are labeled with the [ icon. When you edit an
input field and save your changes, the change applies to all open objects.

To edit multiple objects at the same time:

1. Use Shift + selection or Ctrl + selection to select the objects in the result list.

2. Open the main data form either with Enter, clicking the & icon in the result list, or
selecting Tasks > Edit main data in the context menu.

Committing data on change conflicts

If two users change the same object at the same time, this can cause conflicts when
the object is saved, especially if the same property is changed. In this case, a dialog
box appears when you save the object. You can use this dialog box to view and apply
the changes.

All changes to the object that caused a conflict are shown.

Figure 25: Display of change conflicts

Your changes to object (Harris, Clara (CLARAH)) could not be saved because another user has edited the object. The list below shows you
0 all the changes you have made. Changes that caused the conflict are highlighted in red.
Select all the changes you want to apply or overwrite in the column "Apply’.
Property “our changes Changed by ancther user Lpply? Result
m Primary department Sales und Marketing Service & Support u Service & Support

To apply your changes:

« Active the check box in the Apply column for your values that you wish to save.
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Table 38: About change conflicts

Column Description
Property Property of the object that triggered a change conflict.
Your change Value of the property you entered and wish to save.

Change made by Value of the property that had already been saved by the other user.
other user

Apply? Specify if your value should be applied.

To apply your value, select the check box. Otherwise the system
keeps the value saved by the other user.

Result Current property value.

If you activate the check box in the Apply column, the value you
entered is displayed.
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Working with the Designer

The interfaces of the Manager and Designer have a similar layout. You can find
detailed information about the basic features under One Identity Manager tools user
interface on page 9.

The Designer provides various editors for the One Identity Manager system configuration.
The functionality and the mode of operation of the editors depends on the different
configuration requirements. When you select an object in the Designer, the available
editors are displayed together with the tasks that can be run in the task view.

General tips for the Designer

During the startup process the Designer fills an internal database. SQLite is used for the
database system. This internal database contains the schema and the files from the system
components of the connected One Identity Manager database.

Depending on the program’s configuration, the internal database is either loaded into main
memory or copied to the hard drive of the workstation. To avoid data inconsistencies, only
one instance of the program should be started per database. If the database from the first
instance is copied to hard disk then the databases for all other instances are loaded into
main memory.

All changes to objects in the program are made in the internal database. Permissions,
formatting rules and side-effects of the Customizer are taken into consideration. Changes
made by the user are recorded in a change log. If the internal database is stored on the
hard drive, all additional changes are also logged to this database. This means that you can
restore to the last working state after connecting to the database if the program crashes.

When the data is transferred all recorded changes are made to the One Identity Manager
database. This is done at object level so that, for example, processes are generated and
formatting rules are observed. The principle "last writer wins" applies here as opposed to
the previous object processing. That means that changes have been made by a user to
object properties in the mean time are overwritten.

Depending on the program settings, the internal database is deleted from the hard drive
when the program has finished. This means that all the data has to be loaded from the One
Identity Manager database when the program is restarted. If the internal database is not
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deleted when the program finishes, the next program start up can be accelerated because

only changes from the One Identity Manager that is connected have to be loaded.

Menu items in the Designer

Table 39: Meaning of items in the menu bar

Menu Menu item Meaning Shortcut
Database New Establishes a database connection. Ctrl +
connection Shift + N
Save to Displays the change log. Changes to the data can  Ctrl +
database be saved to the One Identity Manager database. Shift + S
Reload data Data is reloaded from the One Identity Manager
database.
Compile Starts the Database Compiler. Ctrl +
database For detailed information about compiling the Shift+ B
database, see the One Identity Manager
Operational Guide.
Change Opens a dialog box for editing change labels.
management For detailed information about working with
change labels, see the One Identity Manager
Operational Guide.
Check data Opens the Consistency Editor.
consistency For detailed information on checking data
consistency, see the One Identity Manager
Operational Guide.
Start SQL Starts the SQL editor.
editor
Change Changes current user’s password.
password
Settings For configuring program settings.
Exit Exits the program. Alt + F4
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Menu Menu item Meaning Shortcut
View Navigation Activates the navigation view. Ctrl + Q
Tasks Shows or hides the task view. Ctrl+T
Error log Shows or hides the error log. Ctrl + E
Object import Shows or hides the view for importing objects. Ctrl + 1
Search Shows or hides the search dialog box. Ctrl +
Shift +F

Close current
document

Close all
documents

Activate
document

Layout

Enable quick
edit mode

Help Community
Support portal
Training

Online
documentation

Search

Help for the
Designer

transport
history

Info

(GNE IDENTITY

Quest

Closes the current document.

Closes all documents that are open in the
document view.

Shows all open documents in a selection list.

Restores the default layout of the program’s
graphical interface. You can save layouts and load
them again.

The quick edit mode is enabled or disabled.

Opens the One Identity Manager community
website.

Opens the One Identity Manager product support
website.

Opens the One Identity Manager training portal
website.

Opens the One Identity Manager documentation
website.

Opens the search dialog box.

Opens program help. F1

NOTE: Specific help information is available for
each editor.

Display a chronological list of migration, imports,
and exports of transport packages.

Shows the version information for program.
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Table 40: Functions in the standard toolbar

Icon Meaning

& Saves changes to the One Identity Manager database.

€ Shows the previous object in the order that the forms were viewed (object
history).

2 Shows next object in the order they have already been viewed (object history).

0 Database column help. Clicking on the help icon changes the cursor into the help

icon. Then when you click on a column description, tips for using the column are
displayed in the form of tooltips.

D

Prints the edit view. Printer settings are configured in the configuration menus.

Using the help in the Designer

You can access One Identity Manager documentation in the Designer by selecting the Help
> Search in local help menu item.

You can open the general help for Designer from the Help menu or by selecting F1. The
Help menu offers specific help information for each editor.

In addition, a Designer help is available for individual properties of the currently
displayed object. Clicking on the help icon @ changes the cursor into the help icon. Then
when you click on a column description, tips for using the column are displayed in the
form of tooltips.

Views in the Designer

The following views are displayed in the Designer: There are several editors used
for editing data. Their functionality and methods are tailored to the different
configuration tasks.

Table 41: Designer views

View Description

Navigation The navigation structure of the user interface is hierarchical and allows users

view to drill down to the selection of an object definition. The top level of the
hierarchy is used to classify One Identity Manager data into specified categor-
ies.

Document Overview forms and selected editors are displayed in the document view.

view When an object is selected in the navigation view, the corresponding
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View

Description

Task view

Change
log

Error log

Change
label

overview form is displayed.

TIP: If quick edit is enabled, you skip the overview and go straight to the
first editor available for the object.

When you select an object in the navigation view, the available editors are
displayed together with the tasks that can be run. The relevant editor is
opened in the document view when the object is selected.

Changes made by the user are recorded in the change log.

The program'’s error log displays all warnings and error messages that have
occurred since the program started up. When the Designer restarts, the
error log is reinstalled. For detailed information about the error log, see the
One Identity Manager Process Monitoring and Troubleshooting Guide.

In this view, change labels are created and edited. For detailed information
about working with change labels, see the One Identity Manager Operational
Guide.

Related topics

« The editors in the Designer on page 96

« Logging and committing objects in the Designer on page 88

Designer program settings

General configuration settings are specified in a configuration file Designer.exe.config.
Valid global configuration settings can also be defined through the global configuration file
Global.cfg in One Identity Manager's own format. The configuration files are stored in the
program directory. For detailed information, see the One Identity Manager Process
Monitoring and Troubleshooting Guide.

To change the program settings in the Designer

« Inthe Designer, select the Database > Settings menu item.

Related topics

« General tips for the Designer on page 81

« User settings in the Designer on page 86

« General program settings in the Designer on page 87
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User settings in the Designer

On the User tab, configure your user-specific program settings. These settings are stored
in the One Identity Manager database user configuration.

General

« Show balloon tips: Specifies whether speech bubbles, which provide information
about program functionality, are shown in the program.

. Show large images in navigation panes: Specifies whether smaller or larger
icons are displayed on the categories.

. Show additional icons: Specifies whether icons are shown in the task list in
addition to the descriptions.

. Use single clicks: Specifies whether objects are loaded with a single click or by
double-clicking.

. Show additional navigation information: If this option is activated, additional
information is shown for individual interface components.

NOTE: The option is not saved permanently. It has to be reset each time the
program is started.

After starting

« Visible root nodes: The number of categories to be displayed initially in the
navigation view. Changes become effective after a restart.

Behavior

. Enable quick edit mode: Specifies whether quick editing is enabled.

By default, an object's overview form is displayed first. You can, however, configure
the program to show the edit form for the object first, which allows faster editing. In
order to do this quick edit mode has to be enabled. Quick edit mode is indicated by an
additional icon in the program’s status bar.

« Show "Getting Started": Specifies whether the Getting Started category is
shown or hidden.

« Show system data: Specifies whether comprehensive system information such as
system tables, script occurrences, preprocessor dependencies are shown.

. Enable list limit: Specifies whether the number of elements shown in the result list
and list items in controls should be limited.

If this option is enabled, the number of elements must be entered. To do this,
you can choose between the global system settings or the local, personal setting
for the user.
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. Use system settings: Specifies whether the system settings should be used for the
list limit.
If this option is activated, then the global system settings from the Common |

DBConnection | ListLimit configuration parameter are used. If the number of
results is greater than the defined number, a filter dialog opens.

« Objects: Personal setting for the object list limit. If the number of results is greater
than the defined number, a filter dialog opens.

Usage

o Form history length: Number of forms available to browse through in the form
history. You find the form history in the menus attached to the <Back> and
<Forward> buttons in the main toolbar.

. Entries in the search history: Number of entries available in the search history.

Related topics

« Designer program settings on page 85

General program settings in the Designer

On the Program tab, enter the common program settings. These settings are saved in the
registry database on the workstation.

Language settings

. Language: Language used for formatting data, such as date formats, time formats,
and number formats.

. Other user interface language:Language for the user interface. The initial
program login uses the system language for the user interface. Changes to the
language settings take effect after the program has been restarted.The language is
set globally for all One Identity Manager programs, which means the language
setting does not have to be configured for each program individually.

Designer database settings

. Load all system data at program startup: Set the loading behavior for
system data.

If this option is not enable, only the tables that are absolutely necessary are loaded
when the Designer starts. The rest of the table are loaded in background and the user
can already start using the program. The progress of the filling procedure is shown in
the program’s status bar.
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If this option is enabled, all tables are loaded when the program starts. The user
cannot start using the program until all the tables have been loaded. The changes
take effect once the Designer has restarted.

. Load BLOB fields from database on program start: If this option is not
enabled, the contents of binary fields are only loaded when they are required.

If the option is enable, this data is already loaded at program startup. The means
that program startup takes longer.

The changes take effect once the Designer has restarted.

. Save databases locally: If this option is enabled, the internal database is not
deleted when the program ends. This accelerates restarting the program the next
time since only the changes connected with the One Identity Manager database need
to be reloaded.

If the option is not enabled the internal database is deleted from the hard disk when
the program ends. This means that all the data has to be loaded from the One
Identity Manager database when the program is restarted.

« Use RAM to store the system data (no crash recovery): If this option is not
enabled, the internal database is saved on the workstation hard disk.

If the option is enabled, the internal database is loaded into the workstation’s RAM.
In this case the database cannot be restore if the program crashes.

The changes take effect once the Designer has restarted.

. Database directory: If the Save database locally option is enabled, the internal
database is stored in the %LocalAppData%\One Identity\One Identity
Manager\Designer\Cache directory. You save the database somewhere else by
selecting another database directory.

o Clear local cache: Click the button to empty the local cache directory
%LocalAppData%\One Identity\One Identity Manager\Cache.

Related topics

« General tips for the Designer on page 81

« Designer program settings on page 85

Logging and committing objects in the
Designer

All changed objects in the Designer are created in the internal database. Permissions,
formatting rules and side-effects of the Customizer are taken into consideration. Changes
made by the user are also recorded in a change log.
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To display change data in the Designer
o Inthe Designer, select the Database > Commit to database menu item.

The entries in the change log are grouped by editor. Actions (add, change, and delete) that
have been run and changes to the object’s properties with old and new values are displayed
in the log.

Table 42: Icons in the change log

Icon Description

Adds the object.

8 Deletes the object.

n The object has been changed.

The following functions are available in the change log:

« Enable and disable individual changes

You can disable individual changes in the change log. These changes are not
transferred to the One Identity Manager database when the data is saved. You can
however, re-enable changes at a later date. You can enable or disable each change
using the corresponding icon in the change log toolbar.

« Define change label

It is also possible to create a group of all the changes in the change log,
under one label.

« Before saving the recorded changes in the change log, select the required
change label in the Change label menu.

« To assign individual changes to different change labels, use the Special
change label context menu entry in the change log.

When the changes are transferred to the One Identity Manager database, the change
label is applied to the relevant changes. For more information about working with
change labels, see the One Identity Manager Operational Guide.

« Saves changes

All changes are saved to the One Identity Manager database as specified. This is
done at object level so that, for example, processes are generated and formatting
rules are observed. The principle "last writer wins" applies here as opposed to the
previous object processing. That means that changes made by a user to object
properties in the mean time are overwritten.

Table 43: Functions in the change log toolbar

Icon Description

=) Enables change/section.
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Icon Description

& Ignores change/section.
n Edit a change label.

¥ Specifies a default change label. This change label is used for all subsequent
changes.

Related topics

« General tips for the Designer on page 81

Designer-internal full text search

Use full-text search to look for entries within the internal Designer database. You will find
the full text search on its own menu bar in the Designer.

To search for a term

o Enter your search term in the Search field.

You can enter more than one partial terms. You can use * as a wildcard. Case
sensitivity is not taken into account. Entries are searched for that contain all the
partial terms given.

The objects found are entered in a list as you enter the search term.

Figure 26: Displaying the source
Search | last] M |@

gﬂ WI_Attestation_AttestationCase_CheckProposedMewOwner _proposed new owner for any change d

E] Check Proposed Mew Ohwner proposed new owner for any change d
@ HelpDesk.5taff Adtive %P5 P=uid_person[C]Olast=Iastname[COfirsi
@ HelpDesk.5taff. Inactive.2:B% B=uid_person[C]Olast=1astname[C]0first
@ HelpDesk.Staff Active 5P Jelast¥s, Mefirstie

@ HelpDesk. Staff. Inactive.2:B% Felast¥e, Fefirstic

E DPRRevisionStore ~optimize the synchronization by skipp
E WI_AttestationCase_CheckProposedMewOwner .uidProposed OwneriLString TT '--Pri

DialogDashBoardDef (17)
@ fI§ pialogColumn (69)

)
« The icon to the left of the entry shows the entry’s object type (table),e.g. a process,
a table or a menu item.

« The source that the object is extracted from is shown to the right of the entry. The
search term is highlighted by an underline.

. Database tables, object relations and the exact source are also displayed in a tooltip.

« Double-click an entry to switch to the corresponding object.
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If no entries are found for a search term, the system makes suggestions that you can use
as search terms by double-clicking.

Figure 27: Suggestions for search terms

Search | lastkam - |@.

Eﬂ Do you mean...
@ LastMame

@ Last name

@ MName

=

If you have selected an entry, the search term is added to the search history and is
therefore available for further searches.

« Open the search history with the arrow in the search field.
« When you select an entry, all available sources are shown.

The number of entries in the search history depends on your program settings.

Figure 28: Search history

Search | = |@

i" Person
i" lastname

s Refresh index

TIP: Update the full text catalog of the Designer database if you need to include objects
in the search that have been edited after the program started, like new processes or
column names. You do this with Update index, in the search history.

User-defined filters in the Designer

It is possible to limit the number of list entries in certain the Designer editors by using a
filter. After creating a filter, the filter conditions are immediately implemented on the set
of result currently displayed. A filter remains in use until you reset it.

The main components of a user filter are:

o A searchin the objects' display values
o A customized search condition (where clause)

o A full text search

You have the option to set up ad-hoc filters and permanent filters. Ad hoc filters are used
for a one-off reduction of list entries. These filters are not saved and are applied to the
data immediately.

Create a permanent filter if you want to reuse certain search queries on a frequent
basis. Permanent filters are saved in the user configuration and therefore are always
available for use.
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Detailed information about this topic

« Using Adhoc filters in the Designer on page 92

« Creating filter queries using wildcards in the Designer on page 92

« Creating filter queries in the Designer using SQL conditions on page 93
« Creating filter queries using full-text search in the Designer on page 94
« Applying filters in the Designer on page 95

« Publishing filters in the Designer on page 95

Using Adhoc filters in the Designer

Ad hoc filters are used for a one-off reduction of list entries. These filters are not saved and
are applied to the data immediately. The WHERE clause wizard helps you formulate a
condition for database queries. The complete database query is composed internally.

To use an ad-hoc filter in the Designer

1. Inthe Designer, select the Filter > Define filter menu item.

2. Inthe Where Clause Wizard, create the filter condition.

IMPORTANT: Enter the condition for limiting the result set in SQLite notation. The
condition is defined as a valid where clause for database queries. The condition relates to
the selected database table found that is determined when the editor starts.

Related topics

« Wizard for entering database queries on page 44

Creating filter queries using wildcards in
the Designer

The system searches for the search term in the display values of the selected object
definition, using the wildcards.

To create a filter query using placeholders in the Designer

In the Designer, select the Filter > Manage filters menu.
Click New filter.
In the Define a filter dialog, select the Wildcard filter method.

AW

In the Filter parameter pane, enter the following information.
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. Filter objects of: The object definition for the list is already selected.

o Search pattern: Enter the search pattern. You can use * as a wildcard in the
search pattern.

Examples:

Pattern* - searches for all entries whose display value starts with the
Pattern string

*Pattern - searches for all entries whose display value ends with the
Pattern string

*Pattern* - searches for all entries whose display value contains the
Pattern string

Pattern - searches for all entries whose display value matches the
Pattern string

5. To save the filter, enter a name and a description for the search filter in the Save
filter pane and click Save.

6. (Optional) To make the filer available to all users
a. Click Publish.
b. Confirm the security prompt with Yes.
7. (Optional) To apply the filter immediately, click Filter.
8. Select the Database > Save to database and click Save.

Related topics

« Creating filter queries in the Designer using SQL conditions on page 93
« Creating filter queries using full-text search in the Designer on page 94
« Applying filters in the Designer on page 95

« Publishing filters in the Designer on page 95

Creating filter queries in the Designer using
SQL conditions

A condition is used to filter all entries that match the specified condition according to the
selected object definition.

To create a filter query using a SQL condition in the Designer

1. Inthe Designer, select the Filter > Manage filters menu.

2. Click New filter.

3. Inthe Define a filter dialog, select the SQL filter method.

4. Inthe Filter parameter pane, enter the following information.
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. Filter objects of: The object definition for the list is already selected.

. Search pattern: Enter the condition. Enter the condition as a valid database
query WHERE clause. You can enter the database queries as a SQL query
directly or compile the database queries with a wizard. Use the Expert view
and Simple view button to switch to the appropriate view.

5. To save the filter, enter a name and a description for the search filter in the Save
filter pane and click Save.

6. (Optional) To make the filer available to all users
a. Click Publish.
b. Confirm the security prompt with Yes.
7. (Optional) To apply the filter immediately, click Filter.
8. Select the Database > Save to database and click Save.

Related topics

» Creating filter queries using wildcards in the Designer on page 92

» Creating filter queries using full-text search in the Designer on page 94
« Applying filters in the Designer on page 95

« Publishing filters in the Designer on page 95

Creating filter queries using full-text search
in the Designer

NOTE: To use the full-text search, you must run the program over an application server
with an installed search service. For detailed information about installing an application
server for full text search, see the One Identity Manager Installation Guide.

A search query using full-text search, searches for the specified search term in all columns
of the selected object definition that are indexed for full-text search. For detailed
information about configuring columns for the full text search, see the One Identity
Manager Configuration Guide.

To create a filter query in the Designer using the full-text search

1. Inthe Designer, select the Filter > Manage filters menu.

2. Click New filter.

3. Inthe Define a filter dialog, select the Full text filter method.

4. Inthe Filter parameter pane, enter the following information.
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. Filter objects of: The object definition for the list is already selected.

« Search string: Enter the search term. The use of wild cards is permitted. For
examples, refer to Rules and examples for the full-text search on page 75.

5. Inthe Save filter pane, enter a name and a description for the search filter and
click Save.

6. (Optional) To make the filer available to all users
a. Click Publish.
b. Confirm the security prompt with Yes.
(Optional) To apply the filter immediately, click Filter.

Select the Database > Save to database and click Save.

Related topics

« Creating filter queries using wildcards in the Designer on page 92

« Creating filter queries in the Designer using SQL conditions on page 93
« Applying filters in the Designer on page 95

« Publishing filters in the Designer on page 95

Applying filters in the Designer

To use a saved filter in the Designer

1. Inthe Designer, select the Filter > Manage filters menu.
2. Double-click the search filter in the Saved filters pane.
3. Click Filter.

Related topics

« Creating filter queries using wildcards in the Designer on page 92
« Creating filter queries in the Designer using SQL conditions on page 93

« Creating filter queries using full-text search in the Designer on page 94

Publishing filters in the Designer

NOTE: To create, edit, and delete public filters, the user requires the Option to define,
modify, and delete public filters. program function. (Common_PublicFilterDefine).

You can make filters available to all users by publishing them. You have the option to
publish a filter when you create it. Afterward, you can also publish a private filter.
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To publish a filter in the Designer
1. Inthe Designer, select the Filter > Manage filters menu.
2. Double-click the search filter in the Saved filters area.
3. Click Publish.
4. Confirm the security prompt with Yes.
5

Select the Database > Save to database and click Save.

Related topics

« Creating filter queries using wildcards in the Designer on page 92
« Creating filter queries in the Designer using SQL conditions on page 93

« Applying filters in the Designer on page 95

The editors in the Designer

The Designer provides various editors for the One Identity Manager system configuration.
The functionality and the mode of operation of the editors depends on the different
configuration requirements. When you select an object in the navigation view, the available
editors are displayed together with the tasks that can be run.

Table 44: Designer editors

Editor Description

Object Editor The Object Editor is provided for editing single objects. All properties of
an object are represented in table form and can be edited depending on
the permissions situation. In addition, properties such as edit permissions
and column definitions are shown. For more information, see Working
with the Object Editor on page 98.

List Editor The List Editor is used to display result lists and to quickly edit objects and
object relations. Object properties are displayed in tabular form but there
is no additional information about each property as in the Object Editor.
For more information, see Working with the List Editor on page 99.

SQL Editor You can use the SQL Editor to run database queries against the internal
Designer’s SQLite database. For more information, see Working with the
SQL Editor on page 103.

User & Use the User & Permissions Group Editor to create and edit permissions
Permissions  groups and the system user. For more information, see the One Identity
Group Editor Manager Authorization and Authentication Guide.

User Use the User Interface Editor to edit the navigation of the One Identity
Interface Manager tools. For more information, see the One Identity Manager
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Editor

Description

Editor

Form Editor

Overview
Form Editor

Permissions
Editor

Process
Editor

Job Server
Editor

Language
Editor

Schema
Editor

Configuration
Parameter
Editor

Script Editor

Consistency
Editor

Mail
Template
Editor

(GNE IDENTITY

Configuration Guide.

Use the Form Editor to create and edit the interface forms, such as the
main data forms or assignment forms. For more information, see the One
Identity Manager Configuration Guide.

Use the Overview Form Editor to create overview forms. For more inform-
ation, see the One Identity Manager Configuration Guide.

Use the Permissions Editor to edit the permissions structure of the permis-
sions groups and system user. For more information, see the One Identity
Manager Authorization and Authentication Guide.

The Process Editor is the tool that you use to define and change processes
in One Identity Manager. For more information, see the One Identity
Manager Configuration Guide.

You use the Job Server Editor to edit the Job server attributes and the One
Identity Manager Service configuration file. For more information, see the
One Identity Manager Configuration Guide.

For the translation of captions, use the Language Editor. For more inform-
ation, see the One Identity Manager Configuration Guide.

The Schema Editor displays an overview of the entire One Identity
Manager database model. Schema Editor is used to customize table and
column definitions to suit the customer. For example, you can define
formatting rules or formatting scripts with the Schema Editor. For more
information, see the One Identity Manager Configuration Guide.

The Configuration Parameter Editor provides an overview of all the config-
uration parameters in the One Identity Manager and their current values.
For more information, see the One Identity Manager Configuration Guide.

Use the Script Editor to create, edit, and test the custom scripts. For more
information, see the One Identity Manager Configuration Guide.

Use the Consistency Editor to analyze database object for data consist-
ency. A number of tests are offered to test the database and if necessary
run a repair. For more information, see the One Identity Manager Opera-
tional Guide.

Use the Mail Template Editor to create and edit mail templates. For more
information, see the One Identity Manager Operational Guide.
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Working with the Object Editor

The Object Editor is provided for editing single objects. All properties of an object are
represented in table form and can be edited depending on the permissions situation. In
addition, properties such as edit permissions and column definitions are shown.

Detailed information about this topic

« Object Editor menu items on page 98
« Multiple object edit in the Object Editor on page 99

Object Editor menu items

When the editor starts, the following menu items are available in the Designer.

Table 45: Menu items added by the editor

Menu Menu Meaning
item
Object New Creates a new object.
Save Saves all changes to an object.

Delete Deletes current object.
Discard  Returns object to previous state.

Reload Updates the object view.
object

Options Group The object properties are displayed as groups.
view

Column  Column display text is shown. If the option is not enabled, the
names technical names according to the One Identity Manager schema are
shown.

Primary  Shows or hides the primary key.
key

Extended Shows or hides the extended column properties.

Help Object Opens the editor help.

Editor
help
X One Identity Manager 8.2 User Guide for One Identity Manager Tools
(GNE IDENTITY User Interface | o8

Quest
Working with the Designer



Table 46: Meaning of toolbar icons

Icon Meaning

EH The object properties are displayed as groups.

Zi Displays caption/technical name depending on the One Identity Manager schema.
1 f Shows/Hides primary keys.

0] Shows/hides the extended column properties.

Creates object.

B Saves changes.

8 Deletes object.

p>) Resets object to previous state (lose changes).

< Updates object view.

Multiple object edit in the Object Editor

It is possible to edit more than one object of the same object type at the same time in the
Object Editor.

1. Use Shift + select or Ctrl + select to select the entries in the result list.
2. Open the editor from the task view,

The task name contains the number of selected objects. Input fields that have different
values are marked in color. The values entered and saved in the fields are stored for
all objects.

Working with the List Editor

The List Editor is used to display result lists and to quickly edit objects and object relations.
Object properties are displayed in tabular form but there is no additional information about
each property as in the Object Editor.

Detailed information about this topic

« List Editor menu items on page 100

« Functions in the List Editor result list on page 100

« Configuring columns for List Editor result lists on page 101
« Multiple editing of list entries in the List Editor on page 102
« Displaying object relations in the List Editor on page 102
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List Editor menu items

When the editor starts, the following menu items are available in the Designer.

Table 47: Menu items added by the editor

Menu Menu item

Meaning

Object New
Delete
Reload object
Filter  Define filter
Delete filter
Manage filters
View  Properties

Select columns...

Select table
relations

Help List Editor help

Creates a new object.

Deletes current object.

Updates the object view.

Opens a dialog window for creating an ad hoc filter.
Deletes the filter.

Opens a dialog window for creating permanent filters.
Shows or hides the edit view

Opens a dialog window for selecting columns to be displayed
in the list.

Opens a dialog box for selecting object relation to view.

Opens the editor help.

Table 48: Meaning of toolbar icons

Icon Meaning

Creates object.

8 Deletes object.

Copies object to the clipboard.

i} Paste the object or relation from the clipboard. Next to the icon there is a menu to

select the type from.

o Updates object view.
h

User-defined filter for displaying objects.

h A Resets custom filter.

Functions in the List Editor result list

The entries in the result list of the List Editor are displayed with a valid name tag. If an
object is selected in the result list, the object properties and object relations are shown in

(GNE IDENTITY

Quest

One Identity Manager 8.2 User Guide for One Identity Manager Tools
User Interface | 100

Working with the Designer



the edit view. You can limit the number of entries in the result list by setting a filter. For
this you can use an ad hoc filter or a permanent filter.

Table 49: Entries in the result list context menu

Context Menu Meaning

Item

New Inserts a new object.

Delete Deletes selected object.

Copy Copies the selected object into the clipboard.

Paste Inserts the copied object from the clipboard.

Properties Displays the object properties of the selected entry.

Select columns... Opens a dialog window for selecting columns to be displayed in the
list.

Navigation Shows all other editors that can be used with the selected object.

TIP:

« In the table header for the result list, click on a column to sort it by the
selected column.

« You can display further object properties in the result list.

Related topics

« Configuring columns for List Editor result lists on page 101

Configuring columns for List Editor result
lists

To display object properties
In the Designer, select the View > Select column menu item.

2. You specify which object properties should be additionally shown in which order in
the result list. You can also enter the column width and alignment of the column

description.
3. Click OK.
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Table 50: Meaning of toolbar icons

Icon Meaning

Inserts column in view.

] Removes column from view.
H Moves column up.

v Moves column down.

Az

Fa Specifies how columns are labeled. If selected the column names are displayed. If
this option is not active, the identifiers from the data model are shown.

o= The column display is reset to the default settings.

Multiple editing of list entries in the List
Editor

It is possible to edit more than one object of the same object type at the same time in the
List Editor.

« Use Shift + select or Ctrl + select to select the entries in the result list.

Entries in the list that have different input are specially labeled in the edit view. The values
entered and saved in the fields are stored for all objects.

Displaying object relations in the List Editor

To display object relations

1. Select the View > Select table relations menu item.

2. You can specify which object relations are displayed in the List Editor.

Table 51: Entries in the dialog's context menu

Context Meaning
menu item

Show relation  The editing window for the object relationship is displayed in the
editing view of the editor.

Hide relation The editing window for the object relationship is hidden in the
editing view of the editor.

3. Click OK.
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Each relation is shown in its own edit window. To change the assignments, double-click the
icon or choose the required option from the context menu.

Table 52: Meaning of icons in the view

Icon Meaning

=

®

Object is assigned to the selected base object.

Q

Object is not assigned to all selected base objects (multiple entry editing).

Object is not assigned to an object.

Table 53: Items in the view’s context menu

Context Menu Item Meaning

Assign Assign object to the selected base object.

Remove Remove assignment of object to base object.

Properties Displays the object properties of the selected entry.

Navigation Shows all other editors that can be used with the selected object.

Working with the SQL Editor

You can use the SQL Editor to run database queries against the internal Designer’s SQLite
database. This internal database contains the schema and the files from the system
components of the connected One Identity Manager database.

NOTE: To use the SQL Editor in the Designer, the user requires the program function
Option to call the SQL editor in Designer to run SQL statements in the SQL
database (Designer SQLEditor).

Detailed information about this topic

o SQL Editor menu items on page 103
« Running database queries in SQL Editor on page 105

SQL Editor menu items

When the editor starts, the following menu items are available in the Designer.
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Table 54: Menu items added by the editor

Menu Menu item

Meaning

Edit Undo
Redo
Cut
Copy
Paste
Delete

Reduce text indent

Increase text
indent

SQL Run (F5)
Show as table

Help  SQL Editor help

Restores state before last change.

Restores state after last change.

Deletes marked code but save in clipboard.

Copies selected code to the clipboard.

Inserts data stored in the clipboard from copy or cut.
Deletes selected code.

Reduces the indent of the selected code in the query
window.

Increases the indent of the selected code in the query
window.

Runs the query.
Switches output between text and table.

Opens the editor help.

Table 55: Meaning of toolbar icons

Icon Meaning

> Undoes last change.

¢ Redoes last change.

ob Cuts selected code.

Copies selected code into clipboard.

i) Inserts code from clipboard.

(1] Deletes selected code.

= Reduces the indent of the selected code in the query window.
2 Increases the indent of the selected code in the query window.
= Switches output between text and table.

> Runs the query.
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Running database queries in SQL Editor

To run a database query

« Start the SQL Editor in the Designer by selecting the Database > Run SQL
Editor menu item.

« Enter your database query in SQLite notation in the query window. The editor
supports highlighting.

« Run the database query using F5.
The result are displayed in the results window.
| TIP: To sort by a specific column, click on that column in the table header.

TIP: Use Ctrl + C to copy the individual entries or lines to the clipboard. Select
Shift + Select or Ctrl + select to select multiple lines in the table.
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About us

One Identity solutions eliminate the complexities and time-consuming processes often
required to govern identities, manage privileged accounts and control access. Our solutions
enhance business agility while addressing your IAM challenges with on-premises, cloud and
hybrid environments.

Contacting us

For sales and other inquiries, such as licensing, support, and renewals, visit
https://www.oneidentity.com/company/contact-us.aspx.

Technical support resources

Technical support is available to One Identity customers with a valid maintenance contract
and customers who have trial versions. You can access the Support Portal at
https://support.oneidentity.com/.

The Support Portal provides self-help tools you can use to solve problems quickly and
independently, 24 hours a day, 365 days a year. The Support Portal enables you to:

« Submit and manage a Service Request

« View Knowledge Base articles

« Sign up for product notifications

« Download software and technical documentation

« View how-to videos at www.YouTube.com/Oneldentity
« Engage in community discussions

o Chat with support engineers online

« View services to assist you with your product

One Identity Manager 8.2 User Guide for One Identity Manager Tools

(ONE IDENTITY User Interface | 106

Quest
About us


https://www.oneidentity.com/company/contact-us.aspx
https://support.oneidentity.com/
http://www.youtube.com/OneIdentity

Index

A

application server
search index 67, 94

C

consistency icons 25
control

accessibility
$ notation 37
auto-completion 37
syntax highlighting 37

assignments 53

column name 34

database query 43
wizard 44-45

date 49

dynamic foreign key 49

field definition 34

filter 46

form elements 32

input field 33

list of permitted values 36

login times 50

menu 48

multiple value property 36

object relations 51

script 37

shortcut 55

slider 37

translate data 35

(GNE IDENTITY

Quest

Designer 81

change log 88
database search 90
editors 96
empty cache 85
filter 91
adhoc 92
apply 95
full text search 94
publish 95
run 95
SQL condition 93
wild card 92
full text search
run 94
help 84
program setting 85
save changes 88
SQLite 81

filter

Designer 91
Manager 64
wizard 46

filter designer 45

form

form context menu 30

One Identity Manager 8.2 User Guide for One Identity Manager Tools

User Interface | 107

Index



form help 11

form name 30

main data form 30

overview form 30
full text search 90

L

language 59
List Editor 99

column configuration 101

multi edit 102

object relations 102

M

Manager

advanced information 60

category 21
category tab 21
change conflict 79
consistency icons 25
database search 70
document view 30
expert mode 20
favorites list 29
field definition 34
filter 64

apply 68

attach 69

delete 70

edit 70

export 68

full text search 67

import 68
publish 65-68

(GNE IDENTITY

Quest

run 68
SQL condition 66
wild card 65
form 30
form help 11
form name 60
full text search
run 67
help 11
language 59
lists
filter 62, 64
restrict 61
search 63
multi edit 79
navigation object 60
navigation view 21
program setting 56
quick edit mode 56
result list 25
task view 28

view mode 20

o

object
display permissions 78
multi edit 79
object definition 30
show properties 78
Object Editor 98
multi edit 99

One Identity Manager 8.2 User Guide for One Identity Manager Tools

User Interface

Index

108



P

process monitoring
process information

configure display 58

S

SQL Editor 103
database query 105
SQLite 81

)

user
authentication module 13
change password 13
dynamic 13
logged in 13
permissions group 13
program function 13
read permissions 13

system user 13

One Identity Manager 8.2 User Guide for One Identity Manager Tools

(ONE IDENTITY User Interface | 109

Quest
Index



	About this guide
	One Identity Manager tools user interface
	The user interface layout
	Using the help in the Manager
	Status bar information in the Manager
	Current user
	Changing the password of the logged in user

	Menu items in the Manager
	Views in the Manager
	Layout mode in the Manager
	Simple layout mode in the Manager
	Expert mode in the Manager

	Features in the navigation view
	My One Identity Manager

	Functions in the result list
	Features in the task view
	Features in the favorites list
	Features of the document view
	Overview form
	Input field
	Labeling changed data
	Displaying the column names
	Translating entries
	Entering a list of permitted values
	Entering multiple values
	Setting values
	Entering scripts
	Entering database queries
	Entering custom filter conditions
	Selecting from lists
	Selecting a dynamic entry
	Setting a date
	Editing login hours
	Layout of object relations
	Displaying assignments
	General control key combinations


	Manager program settings
	User settings in the Manager
	Special settings for individual program components in the Manager
	General program settings in the Manager
	Plugins available in the Manager

	Reloading changes to the user interface
	Detailed information about the user interface
	Limiting list entries using the list limit
	Limiting list sizes using simple filters
	Searching for list entries
	User-defined filters in the Manager
	Creating filter queries using wildcards in the Manager
	Creating filter queries in the Manager using SQL conditions
	Creating filter queries using full-text search in the Manager
	Applying filters in the Manager
	Publishing filters in the Manager
	Exporting and importing filters in the Manager
	Attaching filters in the Manager
	Editing filters in the Manager
	Deleting filters in the Manager

	Database search in the Manager
	Simple database search
	Running simple database searches using wildcards
	Running simple database searches using full-text search

	Advanced database search
	Creating search queries using wildcards
	Creating search queries using SQL conditions
	Creating search queries using full-text search
	Running advanced database searches


	Displaying extended properties for objects
	Multiple object edit in the Manager
	Committing data on change conflicts

	Working with the Designer
	General tips for the Designer
	Menu items in the Designer
	Using the help in the Designer
	Views in the Designer
	Designer program settings
	User settings in the Designer
	General program settings in the Designer

	Logging and committing objects in the Designer
	Designer-internal full text search
	User-defined filters in the Designer
	Using Adhoc filters in the Designer
	Creating filter queries using wildcards in the Designer
	Creating filter queries in the Designer using SQL conditions
	Creating filter queries using full-text search in the Designer
	Applying filters in the Designer
	Publishing filters in the Designer

	The editors in the Designer
	Working with the Object Editor
	Object Editor menu items
	Multiple object edit in the Object Editor

	Working with the List Editor
	List Editor menu items
	Functions in the List Editor result list
	Configuring columns for List Editor result lists
	Multiple editing of list entries in the List Editor
	Displaying object relations in the List Editor

	Working with the SQL Editor
	SQL Editor menu items
	Running database queries in SQL Editor


	About us
	Contacting us
	Technical support resources

	Index

