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How to change the company logo in the new Angular API Portal
Description
The Administration Portal enables the configuration of HTML Applications.
To change the logo/image, open the API WebShop, log in, and open the Administration Portal:
1. Go to the Configurations tab.
2. Navigate through 'API Server Configuration' section.
3. Add the URL where your image/logo is hosted:
4. Apply changes and reload.
The result is something similar to the following, i.e. a broken image where the logo should be:
Cause
When the logo is not being loaded, and it's displaying the 'broken image' icon, 'Content Security Policy' parameters should be checked.
This is also located in the Administration Portal, just a few options below the Company Logo:
Résolution
To allow/deny the API Portal to load images from other domains, add values on the CSP section on the Administration Portal.
Please note: One Identity cannot assume responsibility for the security implications of the options/values added in this menu. Content Security Policy (CSP) is an added layer of security that helps to detect and mitigate certain types of attacks, including Cross-Site Scripting (XSS) and data injection attacks. Please get in touch with your Security expert if concerns arise.
As an example, the hosted URL is: https://www.itsecurityguru.org/wp-content/uploads/2019/10/Logo_2020-OneIdentity_FullColor_Horizontal.png
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Contenu recommandé
Produit(s) :
Identity Manager
9.1.1, 9.0 LTS
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Sujet(s) :
Technical Solutions
Historique de l’article :
Créé le : 5/2/2023 Dernière mise à jour le : 4/9/2024
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