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Problems with ‘minified’ JavaScript files when proxying applications in Cloud Access Manager.
Description
Form fill can fail to some web applications in Cloud Access Manager because file load errors occur for js files on loading the Login form.
Cause
When Cloud Access Manager proxies an application it rewrites URLs and other code for the page using a series of filters. It has been seen that occasionally the JavaScript rewrite filter can fail to process external JavaScript files that are linked to a web page, where that JavaScript file has been ‘minified’ to optimize download performance. This will appear as a failure to load the file on the initial page load; this can be seen in the browser’s Developer Tools console on Internet Explorer, Chrome or Firefox.
Resolution
To work around this issue first identify the file, or files, that fail to load using the Developer console, then exclude that file or files from the JavaScript rewrite filter. Go to Settings, Show Advanced Settings and select Tune the Cloud Access Manager Proxy in the Cloud Access Manager Administration console. Add an exclude for the JavaScript Proxy filter by selecting the Edit button for the JavaScript Proxy Filter and entering the file name or names in the Exclude field, for example “*file1.js *file2.js”. Wait for the configuration to update (the status icon returns to a green tick) before testing the change.
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Article History:
Created on: 1/10/2014 Last Update on: 5/7/2023
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