When installing or upgrading Cloud Access Manager (CAM), configuration fails registering the database or there are intermittent appearances of a red error bar in the Admin UI
Error: Cloud Access Manager could not connect to database instance
CAUSE 1:
Configuration error when specifying .\MSSQLSERVER in the Data Source field of the Setup Database page
The default instance of SQL Server does not use instance name but rather server name.
CAUSE 2:
DNS Issue. The database server cannot be reached.
CAUSE 3:
Database corruption. Intermittent appearances of that red error bar in the Admin UI are often an indication of issues contacting the DB server.
CAUSE 4:
Permission issue. The account being used does not have rights in the database.
CAUSE 5:
Blocked SQL server port. By default the port is 1443.
CAUSE 6:
Was trying to use a database account during the install (sa). CAM only connects to the DB via Windows Authentication so SQL Server needs to have this auth option enabled. CAM needs to use a Windows account with the sysadmin role, typically a domain administrator; this account is only used to do the initial db creation and configuration and is not stored or used by CAM thereafter.
CAUSE 7:
The Database server and STS server are not in the same domain.
RESOLUTION 1:
1 - Enter ./ in the Data Source field in the Setup Database page or just the server name of the SQL Server
2 - In SQL Server, TCP/IP or named pipes must be allowed. To do this go to SQL Server Configuration Manager by clicking on
Start | Programs | Microsoft SQL Server 2012 | Configuration Tools, and make sure that TCP/IP and Named Pipes are enabled.
For more information please read Connecting Cloud Access Manager to SQL Server and SQL Server Express - KB122070
RESOLUTION 2:
Check DNS configuration by using ping and nslookup and correct any problems found.
1 - From the CAM server:
ping sqlservername
2 - From CAM server:
nslookup sqlsername
RESOLUTION 3:
If this is on production server you may need to restore the CAM databases from backup.
If this is a test environment or a new setup with little data you can delete the databases and uninstall and reinstall CAM.
Prior to reinstall delete the CTAudit, CTData, CTSession & SecurityAnalyticsEngine Databases. Delete the C:\Program Files\Dell folder to remove old logs etc.
used to create a new database for Cloud Access Manager. Click Next.
RESOLUTION 5:
Test to ensure that the port can be communicated on. By default the port is 1433.
From the CAM server:
telnet sqlservername 1433
Note you must have telnet installed to do the above test. Please refer to Microsoft on how to install telnet.
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