ADSAccount update process is failing with the following error: "The server is not operational".
The following error is seen in the job service log:
VI.JobService.JobComponents.ADSComponent - e59693c5-1a3f-4d6b-8e37-1087e77c8c8f: Errors occured
[854003] Processing task ADSAccount Update failed.
[System.Runtime.InteropServices.COMException] The server is not operational.
at StdioProcessor.StdioProcessor._Execute(Job job)
at VI.JobService.JobComponents.ADSComponent.Activate(String Task)
---- Start of Inner Exception ----
at VI.JobService.JobComponents.ADSComponent.Activate(String Task)
at VI.JobService.JobComponents.ADSComponent._ADSACCOUNT_UPDATE()
at VI.JobService.NSProvider.ADSProvider.GetObject(String DistinguishedName)
at VI.JobService.NSProvider.ADSProvider.GetObject(String DistinguishedName, Boolean ForceReload)
at System.DirectoryServices.DirectoryEntry.get_NativeObject() at System.DirectoryServices.DirectoryEntry.Bind()
at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
CAUSE 1:
This can be caused by omitting required parameters on the Sync, such as "SyncServer".
CAUSE 2:
The error "The server is not operational" is caused by an invalid certificate. The validity of a certificate depends on the name of the machine but the job parameter "SyncServer" is empty.
RESOLUTION 1:
Ensure all required fields are filled on the Sync Configuration.
RESOLUTION 2:
Enter the "Domain controller (sync.)" field in the "Active Directory" tab of the domain master data.
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