Hosts have started to become unlicensed automatically and seemingly at random. The masters may still show the host as having a license, but any attempt to issue a pmrun command on the client results in the following error:
$ pmrun -m domain.com su -
pmmasterd: 9006 IP address:192.168.1.17 is not licensed with this master. Please ask your system administrator to license this agent on master.domain.com, using the pmhostlicense utility
Request rejected by pmmasterd on .domain.com
From the master, we can see that the host is registered and licensed:
pmhostlicense -z | grep 42.247
hostlic_linkmap[ 238 ] IP:192.168.1.17 licenseslot:59 time:1296715374 1296715374
Or if it is not registered and licensed, the syslog has the following message
pmhostlicense[4221]: 9015 Removed license for hostname:master.domain.com, data:qmmtloeejsqeenhimqttnmnjijenghse
CAUSE 1:
Certain changes made in the environment can cause the client host to think that it has become unlicensed. For instance, changes affecting the client's hostname or ip address resolution on the client or the master may cause a client to to think it has become unlicensed. This is because the changes may make the client host to appear to be a different host than what the master recognizes.
Product Enahncement 2165 Description in 5.5.2-042 and higher:
A Privilege Manager client can become unlicensed if the registration data for that client changes (this may happen, for instance, if a virtual machine is migrated to different hardware). To safeguard against this, the registration data is now stored on the client.
To forcibly re-generate and overwrite any stored registration data, the "pminfo -r -r" command can be run on the client.
CAUSE 2:
Accidental deletion of license with pmhostlicense -d -h master.domain.com
With the host licensing in Privilege Manager, a client host should remain licensed with the master until it is manually unlicensed.
RESOLUTION 1:
1 - Compare the registration data for the client with the master.
On the client run /opt/quest/sbin/pminfo -s
On the master /opt/quest/sbin/pmhostlicense -af
2 - If these do not match, then the old registration data for the client should be removed
/opt/quest/sbin/pmhostlicense -di <reg_data>)
3 - Re-register the client host
/opt/quest/sbin/pminfo -r
4 - Re-license the client host
/opt/quest/sbin/pmhostlicense -lh <hostname>
RESOLUTION 2:
1 -Re-register the client host
/opt/quest/sbin/pminfo -r
2 - Grant license to registered host
/opt/quest/sbin/pmhostlicense -lh <hostname>
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