The vasd process is using a high amount of CPU.
In some instances, vasd debug may show a lot of check_access output repeated for hundreds of users and over a long period of time such as:
Feb 12 10:58:02 joe_user daemon:debug vasd[44499372]: check_access_cached: allowed file does exist, user_allowed = 0, group_allowed = 0, ou_allowed = 0, realm_allowed = 0, userWorkstations_allowed = 0
CAUSE 1:
Product Defect 27914:
.* vasd: When processing ac files, ignore duplicates instead of marking theprocessing invalid triggering another processing in 30 seconds, over and over.
The duplicate id's in the users.allow file cause vasd to process the users.allow file over and over and utilize a high amount of CPU.
CAUSE 2:
Operating system configuration - Ulimit or maximim number of files limit
WORKAROUND 1:
1 - Edit the /etc/opt/quest/vas/users.allow file
Remove the duplicate
STATUS 1:
The defect is fixed in QAS 4.0.3.185 and up
RESOLUTION 1:
Upgrade to QAS latest Maintenance Release.
Please go to https://support.oneidentity.com/authentication-services/download-new-releases
RESOLUTION 2:
Increase the number maximum of open files.
For instructions please refer to the operating system vendor's documentation.
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