Submitting forms on the support site are temporary unavailable for schedule maintenance. If you need immediate assistance please contact technical support. We apologize for the inconvenience.
This article details the syslog-ng syntax tool which allows for the verification of a valid syslog-ng configuration.
Cause
Once a syslog-ng configuration is created it needs to be verified to ensure its validity before starting the syslog-ng service with the created configuration.
Resolution
These steps must be completed from within the Syslog-ng PE Linux environment.
With root privileges please run the following command from within the Linux environment which is running the Syslog-ng PE instance
Replace "/opt/syslog-ng/etc/syslog-ng.conf" with the location of the syslog-ng configuration file if not using the default location.
The -ng service will then run a syntax check against the -ng configuration file to ensure its validity.
If nothing is returned from within the terminal once the syslog-ng syntax tool has been run, then the configuration file is valid.
If a syntax error is found after running the syslog-ng syntax tool the error will be displayed within the terminal which will state where the syntax error is located.
For knowledge:
-s informs the syslog-ng service to perform a syntax verification
-v informs the syslog-ng service to perform the syntax verification verbosely
-f informs the syslog-ng service to use a specific configuration file which is then specified
the -svf syntax within this command combine the above syntaxes to perform the syslog-ng syntax verification of the configuration file verbosely using a configuration file specified.
Additional Information
This tool is for verifying the syntax validity of the configuration only. This tool does not scan for configuration errors that may not cause syslog-ng to perform as desired, therefore any errors in the configuration that are not syntax errors, will not be found using this tool.
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Welcome to One Identity Support
You can find online support help for*product* on an affiliate support site. Click continue to be directed to the correct support content and assistance for *product*.
The One Identity Portal no longer supports IE8, 9, & 10 and it is recommended to upgrade your browser to the latest version of Internet Explorer or Chrome.