Chat now with support
Chat with Support

Safeguard Authentication Services 4.1.5 - Upgrade Guide

One Identity Privileged Access Suite for Unix Introducing One Identity Authentication Services What's new in Authentication Services 4.1 Upgrade from 3.5 to 4.1 considerations Upgrade the web console Upgrade Authentication Services Windows components Configure Active Directory for Authentication Services Configure Unix agent components Upgrade Authentication Services client components manually Getting started with Authentication Services Troubleshooting

Licensing Authentication Services

Authentication Services must be licensed in order for Active Directory users to authenticate on Unix and Mac OS X hosts.

Note: When upgrading, Authentication Services continues to use licenses from previous versions. This allows the upgrade to take place without having to distribute new license files first. Any VAS 3.x or higher license is valid for Authentication Services 4.1.

Note: While you can install and configure Authentication Services on Windows and use the included management tools to Unix-enable users and groups in Active Directory without installing a license, you must have the Authentication Services license installed for full functionality.

Contact your account representative for a license.

System requirements

Prior to installing Authentication Services, ensure your system meets the minimum hardware and software requirements for your platform. Authentication Services consists of Windows management tools and Unix client agent components.

Related Topics

Windows management tools requirements

Authentication Services Windows components

Windows permissions

Unix agent requirements

Authentication Services Unix components

Authentication Services permissions matrix

Authentication Services encryption types

Management Console for Unix requirements

Windows management tools requirements

The following are the minimum requirements for installing Authentication Services in your Windows environment:

Table 1: Authentication Services Windows requirements
System Requirements:

Supported Windows Platforms

You can install Authentication Services on 32-bit or 64-bit editions of the following configurations:

  • Windows XP SP2 (or later)
  • Windows Vista
  • Windows 7
  • Windows 8
  • Windows Server 2003 SP1 (or later)
  • Windows Server 2008
  • Windows Server 2008 R2
  • Windows Server 2012

NOTE: Due to tightened security, when running Authentication Services Control Center on Windows 2008 R2 (or higher) operating system, functioning as a domain controller, the process must be elevated or you must add authenticated users to the Distributed COM Users group on the computer. As a best practice, One Identity does not recommend that you install or run the Authentication Services Windows components on Active Directory domain controllers. The recommended configuration is to install the Authentication Services Windows components on an administrative workstation.

Prerequisite Windows Software

You can download all of the following prerequisite software free from the Microsoft website:

Authentication Services Windows components

Authentication Services includes the following Windows components:

Table 2: Windows components
Windows Component Description

Authentication Services Control Center

A single console for access to all of the tools and configuration settings for Authentication Services.

Active Directory Users and Computers MMC Snapin Extensions

Unix management extensions for Active Directory users and groups.

Group Policy Management Editor MMC Snapin Extensions

Group Policy extensions for management of Unix, Linux and Mac OS X.

RFC2307 NIS Map Editor MMC Snapin

Provides the ability to manage NIS data in Active Directory.

NIS Map Import Wizard

Imports NIS data into Active Directory.

Unix Account Import Wizard

Imports Unix identity data into Active Directory.

Authentication Services PowerShell cmdlets

Provides the ability to script Unix management tasks.

Documentation

Full product documentation and online help.

Note: The VAS Configuration Utility is no longer included. Instead the Control Center provides access to all preferences and tools. If you were using the custom schema functionality of the VAS Configuration Utility, be sure to configure the same settings in the Control Center under Preferences | Custom Unix Attributes.

Any previous version of the Authentication Services Windows components are automatically uninstalled before the Authentication Services 4.1 install proceeds.

Related Documents