Error when adding a Service Now ticket system {"Code":60414,"Message":"Failed to connect to ticket system 'dev' (https://fqdn.service-now.com/oauth_token.do): Reason: An error occurred while sending the request. - The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.","InnerError":null}
or when entering ticket number:
"Failed to connect to ticket system 'ticket_system_name' (https://fqdn.service-now.com/oauth_token.do): Reason: An error occured while sending the request - The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. (60414)"
原因
The https://service-now.com root certificate must be added to the Safeguard trusted certificate store for Ticketing communication to work.
解决办法
Download the Entrust Root Certificate Authority and Entrust Root Certificate Authority—G2 root certificates from Entrust
To install the certificate into Safeguard:
From the Primary go to Settings, select Certificates | Trusted Certificates
Click + Add Certificate from the details toolbar.
Browse to select the downloaded Certificate file.
Click Open to add the selected certificate file to Safeguard.