You receive a sync error that The RPC server is unavailable. (Exception from HRESULT: 0x800706BA) when committing workflow changes in Quick Connect to create user accounts in Active Directory using the Quick Connect for AD connector.
The Quick Connect server is unable to contact the RPC server service on domain controller it's connecting to.
Cause 1
There may be an issue with the domain controller being contacted (firewall, etc.).
Cause 2
The DNS being used is not configured properly.
Cause 3
An IP address is being used to specificy a domain controller in the Active Directory connection settings.
Cause 4
The Remote Procedure Call (RPC) Locator service is not started on the capture agent host.
Workaround 1
Make sure RPC exceptions are enabled in the firewall or disable the firewall completely. Try specifying a domain controller's FQDN (Fully Qualified Domain Name) to point directly to a specific host; this can help narrow down if it's an issue with only one domain controller.
Workaround 2
Troubleshoot the DNS configuration. You can try adding an entry for the domain controller in the HOSTS file on the Quick Connect server to allow the connection to be properly established.
Workaround 3
Using an IP address for a domain controller to create user accounts is not supported. You must specify the FQDN (Fully Qualified Domain Name) of the domain controller you want to connect to rather than just an IP address.
Workaround 4
On the capture agent host, start the Remote Procedure Call (RPC) Locator service and restart the server.