RDP connection freezes soon after the initial connection through SRA
说明
When establishing an RDP connection through Safeguard Remote Access joined to SPS, the session will connect successfully, but the screen will freeze after 2 minutes. This is reproducible and happens every time.
原因
During an SRA session, SPS uses a control channel connected to our Azure based service (sra-ygg-prd-usw.servicebus.windows.net = 138.91.242.98) via tcp/443. This control channel has a low-traffic profile, it is mostly silent, there are gaps (several minutes long) between data exchanges.
In this case, there was an intermediary, such as a router or firewall, that was closing the connection after 120 seconds. When the connection was closed, it cause the RDP connection to freeze.
解决办法
A defect has been to submitted to the product team for review. The proposed solution is to introduce a keep-alive and auto-reconnect functionality, which will assist in maintain the RDP session, in case of a timeout. This change is expected to be included in the SPS 6.12 release.