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Titolo
New user creation attestation is not giving an option to set the manager
Descrizione
After a new user creates an account using the self service portal an attestation is created to be approved. When the attestor attempts to approve the attestation there is no option to set the manager. In previous versions of Identity Manager this option existed.
Causa
The attestation policy "New user certification" now looks for users where IsExternal = 1. This has changed the behavior of the web portal when attesting the object.
Risoluzione
Follow the steps below to use an extension to update the self service portal so that it no longer marks the user as External.
Open up Web Designer and login with an applicable account
Click on Navigation and select the VI_UserRegistration_Start module
Right click on Initializer and select Object in extension > Add to custom configuration > Data actions > Insert
Select the original Insert:Person node and right click
Select Delete node as an extension > Add to custom configuration
Select the new custom extension (the old one is grey in color)
In the Node editor set the collection to PersonNew
Right click Insert: PersonNew and select Insert column value
Enter the same columns as the old one (the new ones will be purple)
Ensure to set the IsExternal to false instead of true
Save the changes
Publish the changes to the web portal
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Prodotto/i:
Identity Manager
Argomento/i:
How To
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Data di creazione: 6/2/2020 Ultimo aggiornamento: 5/7/2023
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