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Slow search performance in the Active Roles Web Interface
설명
In Active Roles 7.6.1, Active Roles 8.0 LTS, or Active Roles 8.1, after making any customization in the Active Roles Web Interface, the Quick Search and Advanced Search may take significantly longer to return results when searching from the Active Directory or AD LDS (ADAM) nodes.
In some environments this issue may cause significant CPU and memory usage.
This issue can also present as extremely high CPU utilization on the Active Roles Administration Service host, with all CPU resources being used by the ARAdminSVC process.
Performance is normal when not searching from the Active Directory or AD LDS (ADAM) nodes.
A new Active Roles Web Interface configuration does not display the same issue.
In the Active Roles Administration Service verbose logging, the search request shows that a very large LDAP filter is being processed. Please see the attached screenshot from the Active Roles Log Viewer.
원인
This issue has been identified as an Active Roles defect and is being tracked as Defect ID 395064.
해결 방안
WORKAROUND
Download and run the attached PowerShell script named Check_edsaWICommands_395064.ps1
This script does not perform any modifications, but will query all Active Roles Web Interface configurations that are stored in your Active Roles Configuration database to see if any of those configurations are affected by Defect ID 395064
This script should be executed on the Active Roles Administration Service host as an Active Roles Admin. It can be executed in a standard PowerShell session or in the PowerShell ISE.
If the script flags any customizations as being affected by this defect, please contact Support and reference this solution.
STATUS
This issue has been addressed in Active Roles 8.1.3 and Active Roles 8.0.1 LTS. Active Roles Web Interface configurations created or modified in those versions will no longer be affected by this issue.