Submitting forms on the support site are temporary unavailable for schedule maintenance. If you need immediate assistance please contact technical support. We apologize for the inconvenience.
Error, timeout, or poor performance when accessing groups or group membership in Active Roles
설명
All Active Roles clients are slow when listing groups and when viewing the memberOf tab of any Active Directory object.
Results are returned, but they are paged or "chunked" in 25 objects at a time.
Verbose logging shows that these delays are not in the Active Roles Administration Service but are in the client. In extreme cases, there might also be a timeout error or the error:
The parameter is incorrect
Error when getting next 25 records. Serialization failure occurred when reading an element with WS_READ_OPTION '2'.
원인
The slowness and timeouts are caused by having a Managed Unit that targets the Group object members attribute.
This issue is being tracked as Defect ID 417065.
해결 방안
WORKAROUND Delete all Managed Units that contain a query that targets the members attribute of a Group.
STATUS Waiting for fix in a future release of Active Roles.