DBQueue Processor does not process tasks
Possible issues
- After restoring a One Identity Manager database from a database backup, no DBQueue Processor tasks are handled.
- If the SQL Server in running on a virtual machine and the virtual machine is suspended, it is possible that no DBQueue Processor tasks are handled after restarting the virtual machine.
Probable reason
The SQL Server Service Broker cannot be reactivated during initialization of the DBQueue Processor. The Service Broker is implemented for DBQueue Processor communications.
Solution
Execute the following steps using a suitable program for executing SQL queries in the database:
IMPORTANT: Select a user that you use for migrating the database to execute the SQL queries.
- Stop all DBQueue Processor components.
exec QBM_PWatchDogPrepare 1
go
exec QBM_PDBQueuePrepare 1
go
- Check whether other database sessions are active.
select *
from sys.sysprocesses p
where dbid = DB_ID()
and spid <> @@SPID
If there are still sessions active, they must be closed first.
- Create a new ServiceBroker ID and enable message delivery.
alter database <database name> set NEW_BROKER
go
alter database <database name> set enable_broker
go
- Initializing the DBQueue Processor.
exec QBM_PDBQueuePrepare 0,1
go
exec QBM_PWatchDogPrepare
go
Message: Enter email address in configuration parameter
In a process for sending emails, the value of the SenderAddress or Address parameter is <Enter email address in configuration parameter "...">. Check process parameters in Job Queue Info.
The message is also sent to the One Identity Manager Service log file if extended error reporting in debug mode is configured for the One Identity Manager Service.
Probable issue
One Identity Manager sends email notifications about various actions taken within the system. One Identity Manager email notification system is not completely configured.
Solution
- In the Designer, check the configuration parameters of the email notification system in the Base data | General | Configuration parameters category and customize the values.
Detailed information about this topic
Operations Support Web Portal is not displayed
Problem
An empty page is displayed in the Internet Explorer if the Operations Support Web Portal is opened with the URL.
Possible cause
The Operations Support Web Portal should be displayed on an intranet page and the Display intranet sites in compatibility view setting enabled in the web server.
Solution
In the configuration file (web.config) of the Web Portal application, extend the <system.webServer> section. Enter an attribute or compatibility mode:
<system.webServer>
...
<httpProtocol>
<customHeaders>
...
<add name="X-UA-Compatible" value="IE=11" />
...
</customHeaders>
</httpProtocol>
</system.webServer>
Removing superfluous modules
You can remove modules from the One Identity Manager database that you no longer require in your system.
IMPORTANT:
-
By removing a module, you lose all the data that goes with it. So it is important to make a backup of the One Identity Manager database before removing any modules.
-
In certain circumstances, dependencies to other modules may be deleted by removing a module. Therefore, update the One Identity Manager schema after removing a module.
-
Other tests may be necessary after removing a module. Remove the module in your test environment first and test the One Identity Manager functionality thoroughly. Make sure to also check any custom adaptations that may use functions in the modules that have been removed.
To remove a module
-
Terminate all web applications using the Internet Information Services (IIS) Manager.
-
Close all One Identity Manager tools except for Job Queue Info.
-
Wait until all processes have terminated. You can do this using the .
-
Close all One Identity Manager Services through the services manager.
-
Terminate all application servers using the IIS Manager.
-
Wait until all DBQueue Processor tasks have completed. You can do this using the .
-
Close Job Queue Info.
-
Start a suitable program for executing SQL queries.
IMPORTANT:
-
Select a user that you use for migrating the database to execute the SQL queries.
-
Execute the following steps separately using a suitable program for executing SQL queries.
Test the output of the query after each step. The output provides additional advice about removing a module.
-
Activate single-user mode for the One Identity Manager database.
exec dbo.QBM_PSingleUserRequest @@spid
-
Stop the DBQueue Processor components.
exec QBM_PWatchDogPrepare 1
go
exec QBM_PDBQueuePrepare 1
go
-
Delete all triggers in the database.
exec QBM_PTriggerDrop '%', @force = 1
-
Delete all constraints in the database.
exec QBM_PConstraintFKDrop '%','%','%'
-
Delete the module you no longer need.
exec QBM_PModuleRemove '<3-character module abbreviation>'
declare @ModulesToRemove varchar(100) = 'SAP' + char(7)
+ 'SHR' + char(7)
+ 'SBW' + char(7)
+ 'SAC' + char(7)
exec QBM_PModuleRemove @ModulesToRemove
go
-
If you delete the Business Roles Module (RMB), you must also delete the entries in the OrgRoot table.
exec QBM_PDeleteDeep '<Key><T>OrgRoot</T><P>3031e9af-6a53-4876-bbfb-0f7fbf264131</P></Key>
-
End single-user mode for the One Identity Manager database.
exec dbo.QBM_PSingleUserRelease @@spid
-
Update the One Identity Manager schema with the Configuration Wizard. Select all remaining modules for updating.
-
If support sent you hotfixes for this version, then these hotfixes must also be reinstalled.
-
Start the application server, the One Identity Manager Services and the web applications.