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Identity Manager 9.1 - Installationshandbuch

Über dieses Handbuch Überblick über den One Identity Manager Installationsvoraussetzungen Installieren des One Identity Manager Installieren und Konfigurieren des One Identity Manager Service Automatisches Aktualisieren des One Identity Manager Aktualisieren des One Identity Manager Installieren zusätzlicher Module für eine bestehende One Identity Manager Installation Installieren und Aktualisieren eines Anwendungsservers Installieren des API Servers Installieren, Konfigurieren und Warten des Web Designer Web Portals Installieren und Aktualisieren der Manager Webanwendung Anmelden an den One Identity Manager-Werkzeugen Fehlerbehebung Erweiterte Konfiguration der Manager Webanwendung Maschinenrollen und Installationspakete Konfigurationsparameter für das E-Mail-Benachrichtigungssystem Einsatz der One Identity Manager-Datenbank mit SQL Server AlwaysOn-Verfügbarkeitsgruppen konfigurieren

Fehlerbehebung

Ausführliche Informationen finden Sie im One Identity Manager Handbuch zur Prozessüberwachung und Fehlersuche.

Transporthistorie anzeigen und One Identity Manager Version prüfen

Bei einer Schemainstallation oder Schemaaktualisierung mit dem Configuration Wizard werden das Migrationsdatum und der Migrationsstand in der Transporthistorie der Datenbank aufgezeichnet.

Beim Importieren eines Transportpaketes mit dem Database Transporter werden das Datum des Imports, die Beschreibung des Imports, der Versionsstand der Datenbank, der Name des Transportpaketes in der Transporthistorie der Zieldatenbank aufgezeichnet.

Um die Transporthistorie anzuzeigen

  • Starten Sie den Designer und wählen Sie das Menü Hilfe > Transporthistorie.

Um einen Überblick über die Systemkonfiguration zu erhalten

  • Starten Sie den Designer oder den Manager und wählen Sie das Menü Hilfe > Info.

    Auf dem Tabreiter Systeminformationen erhalten Sie einen Überblick über Ihre aktuelle Systemkonfiguration und die installierten Module mit ihren Versionen.

    WICHTIG: Stellen Sie diese Informationen bereit, wenn Sie den Support kontaktieren.

    HINWEIS: Wenn Sie die Lieferantenbenachrichtigung aktiviert haben, wird dieser Bericht einmal im Monat an One Identity gesendet.

Verwandte Themen

Fehlermeldungen bei der Anmeldung an den One Identity Manager-Werkzeugen

Problem

Bei der Anmeldung an einem One Identity Manager- Werkzeug erscheint folgende Fehlermeldung:

[810284] Der Benutzer konnte nicht authentifiziert werden.

[810015] Die Anmeldung des Benutzers xyz ist gescheitert.

[810017] Falscher Benutzername oder falsches Kennwort.

Mögliche Ursachen
  • Der angegebene Benutzer wird durch das gewählte Authentifizierungsmodul nicht unterstützt.

  • Das angegebene Kennwort ist falsch.

  • Der Benutzer, der zur Anmeldung verwendet wird, ist gesperrt.

  • Die Person, die zur Anmeldung verwendet wird, ist temporär oder dauerhaft deaktiviert.

  • Die Person, die zur Anmeldung verwendet wird, ist als sicherheitsgefährdend eingestuft.

Mögliche Lösungen
  • Prüfen Sie die Anmeldeinformationen.

  • Prüfen Sie, ob die Person, die zur Anmeldung verwendet wird, gesperrt ist. Nutzen Sie im Manager in der Kategorie Personen die folgenden Menüeinträge.

    • Inaktive Personen: Es werden die zeitweilig deaktivierten Personen und die dauerhaft deaktivierten Personen angezeigt.

    • Sicherheitsvorfälle: Es werden die Personen angezeigt, die als sicherheitsgefährdend eingestuft sind.

    • Gesperrte Personen: Es werden die Personen angezeigt, die die Anzahl der maximalen Fehlanmeldungen überschritten haben und somit gesperrt sind.

  • Prüfen Sie, ob der Systembenutzer, der zur Anmeldung verwendet wird, gesperrt ist. Gesperrte Systembenutzer werden im Designer in der Kategorie Berechtigungen > Systembenutzer > Gesperrte Systembenutzer angezeigt.

Ausführliche Informationen zu deaktivierten Personen finden Sie im One Identity Manager Administrationshandbuch für das Identity Management Basismodul.

Kennwörter gesperrter Personen und Systembenutzer können im Kennwortrücksetzungsportal zurückgesetzt werden. Damit werden die Personen und Systembenutzer wieder entsperrt. Ausführliche Informationen finden Sie im One Identity Manager Web Designer Web Portal Anwenderhandbuch und im One Identity Manager Konfigurationshandbuch für Webanwendungen.

Problem

Bei der Anmeldung an einem One Identity Manager-Werkzeug erscheint folgende Fehlermeldung:

[810374] Sie dürfen diese Anwendung nicht ausführen.

Ursache

Das Starten der One Identity Manager-Werkzeuge ist nur zulässig, wenn der Benutzer die entsprechenden Programmfunktionen besitzt. Sie verwenden zur Anmeldung eine Systembenutzerkennung, die nicht die Berechtigung zum Starten des Programms besitzt.

Mögliche Lösungen
  • Verwenden Sie eine Systembenutzerkennung, die die benötigte Programmfunktion zum Starten des Programms benötigt.

  • Stellen Sie dem Systembenutzer die Programmfunktion zur Verfügung.

    • Prüfen Sie im Designer in der Kategorie Berechtigungen > Programmfunktionen, welche Berechtigungsgruppe die erforderliche Programmfunktion besitzt.

    • Für nicht-rollenbasierte Anmeldung: Nehmen Sie im Designer in der Kategorie Berechtigungen > Systembenutzer den Systembenutzer in die Berechtigungsgruppe auf.

    • Für rollenbasierte Anmeldung: Stellen Sie sicher, dass der Benutzer der Anwendungsrolle zugewiesen ist, welche die Programmfunktion besitzt.

Ausführliche Informationen zu den One Identity Manager Authentifizierungsmodulen, zu Berechtigungsgruppen und Anwendungsrollen sowie zu den Programmfunktionen finden Sie im One Identity Manager Handbuch zur Autorisierung und Authentifizierung.

Fehlermeldungen bei der Installation und der Aktualisierung der One Identity Manager-Datenbank

Bevor die Installation oder Aktualisierung der One Identity Manager-Datenbank startet, prüft der Configuration Wizard die Einstellungen des Datenbankservers und der Datenbank, die für die Installation und den Betrieb der One Identity Manager-Datenbank erforderlich sind. Weitere Informationen finden Sie unter Einstellungen für den Datenbankserver und die One Identity Manager-Datenbank auf einem SQL Server.

Einige dieser Einstellungen werden durch den Configuration Wizard korrigiert. Ist die Korrektur nicht möglich, wird eine entsprechende Meldung im Configuration Wizard ausgegeben. Korrigieren Sie in diesem Fall die Fehler manuell.

Tabelle 40: Meldungen im Configuration Wizard vor dem Start der Installation oder der Aktualisierung einer Datenbank

Meldung

Lösung

Das Datenbanksortierschema stimmt nicht. 'SQL_Latin1_General_CP1_CI_AS' muss konfiguriert sein.

Setzen Sie die Datenbankeigenschaft Sortierung (Collation) auf den Wert SQL_Latin1_General_CP1_CI_AS.

Die Migration kann nicht ausgeführt werden, da gerade eine Replikation ausgeführt wird.

Weitere Informationen finden Sie unter Datenbankfehler bei der Migration einer Datenbank in SQL Server AlwaysOn-Verfügbarkeitsgruppen.

Der Wert in 'DialogDatabase.DataOrigin' ist ungültig. Führen Sie erst eine Datenbankkompilierung durch.

Verwenden Sie den Database Compiler, um die Datenbank-ID neu zu erzeugen und die Datenbank zu kompilieren. Es müssen alle Anteile der Datenbank neu kompiliert werden. Achten Sie darauf, dass alle Skriptausdrücke und alle Prozesse zur Kompilierung gekennzeichnet sind.

Die Datenbank besitzt keine Datendateigruppe für In-Memory-OLTP.

Verwenden Sie die Reparaturmethode um eine Datendateigruppe zu erstellen.

Die Datenbank hat keine Datei in der Datendateigruppe für In-Memory-OLTP definiert.

Verwenden Sie die Reparaturmethode um eine Datenbankdatei zu erstellen. Die Datei wird im Verzeichnis der Datendatei (*.mdf) erstellt.

Der SQL Server hat In-Memory-OLTP nicht aktiviert.

Setzen Sie die Datenbankservereigenschaft Extreme Transaktionsverarbeitung unterstützt (Is XTP Supported) auf den Wert True.

Die Datenbankeigenschaft 'Abbruch bei arithmetischem Fehler aktiviert (Arithmetic Abort enabled)' ist nicht aktiviert.

Setzen Sie die Datenbankeigenschaft Abbruch bei arithmetischem Fehler aktiviert (Arithmetic Abort enabled) auf den Wert True.

Die Datenbankeigenschaft 'Bezeichner in Anführungszeichen aktiviert (Quoted Identifiers Enabled)' ist nicht aktiviert.

Setzen Sie die Datenbankeigenschaft Bezeichner in Anführungszeichen aktiviert (Quoted Identifiers Enabled) auf den Wert True.

Eine Migration kann nicht ausgeführt werden, wenn das Wiederherstellungsmodel nicht 'Einfach (Simple)' ist.

Setzen Sie die Datenbankeigenschaft Wiederherstellungsmodell (Recovery model) auf den Wert Einfach (simple).

Der Transaktionsmodus kann nicht gesetzt werden, da andere Benutzer aktiv sind.

Beenden Sie die Verbindungen anderer Benutzer zur Datenbank.

Die Jobqueue und / oder die DBQueue ist nicht leer. In der Dokumentation erhalten Sie weitere Informationen und Lösungsvorschläge zu dieser Prüfung.

Stellen Sie sicher, dass die Prozesse in der Jobqueue und die Aufträge in der DBQueue vor dem Start der Aktualisierung verarbeitet wurden. Verwenden Sie Job Queue Info zur Überwachung der Prozessverarbeitung. Ausführliche Informationen finden Sie im One Identity Manager Handbuch zur Prozessüberwachung und Fehlersuche.

Der Configuration Wizard bietet eine Möglichkeit, diese Meldung zu ignorieren. Verwenden Sie diese Möglichkeit nur in Testumgebungen oder Entwicklungsumgebungen. Durch die Aktualisierung der Datenbank können Änderungen erfolgen, die dazu führen, dass die Prozesse anschließend nicht mehr verarbeitet werden können.

Der Systembenutzer 'viadmin' muss ein gültiges und nicht leeres Kennwort haben.

Stellen Sie sicher, dass der Systembenutzer ein gültiges Kennwort besitzt.

Die Datenbank befindet sich im Status 'Initialmigration'. Der Configuration Wizard kann dadurch nicht ausgeführt werden.

Die initiale Schemainstallation der Datenbank wurde nicht vollständig abgeschlossen. Dies kann unterschiedliche Ursachen haben, beispielsweise nicht erreichbarer Datenbankserver oder Clusterschwenks während der Schemainstallation.

Erstellen Sie ein neue Datenbank und führen Sie erneut eine initiale Schemainstallation aus. Weitere Informationen finden Sie unter Installieren und Konfigurieren einer One Identity Manager-Datenbank.

Die SQL Server Anmeldung, welche in QBMDBPrincipal.LoginName angegeben ist, existiert nicht.

Verwenden Sie die Reparaturmethode um die SQL Server Anmeldung zu erstellen.

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