Microsoft Authenticator and Google (TOTP) token is displaying 'Bad response' after performing the Reset operation on the token
説明
When using the RESET option on specific mobile tokens, it causes the token responses to show as 'Bad response' when validated by Defender.
The issue is dependent on the Mobile token application and activation type, If the Mobile token app supports counter-based activation, then RESET will work and not cause any issues.
Google Authenticator app provides support for both modes of activation that is time (TOTP) and counter based (HOTP) activation, but Microsoft Authenticator supports time-based activations only.
原因
The issue is related to Google (TOTP) and Microsoft Authenticator tokens being time-based tokens.
対策
STATUS: Enhancement Request 403967 has been created to address this issue in a future release of Defender.
WORKAROUND: Use OATH Compliant tokens as those are not affected by this issue and are considered counter-based. If you must use Google Authenticator (TOTP) or Microsoft Authenticator (Time based), then you would have to delete the existing token and program new token for the user to workaround the issue.