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Identity Manager Data Governance Edition 9.1 - Deployment Guide

One Identity Manager Data Governance Edition Deployment Guide Data Governance Edition system requirements Install One Identity Manager Data Governance Edition Deploy Data Governance Edition components Post installation configuration Authentication using service accounts and managed domains Working with managed hosts and agents Upgrade Data Governance Edition Remove Data Governance Edition Troubleshooting NetApp managed host deployment EMC managed host deployment SharePoint Farm managed host deployment

Exporting agent log

From the Agents view in the Manager, you can export the agent log for the selected agents to a location of your choosing. The log files are exported through a background operation and will exist once the background operation has completed. The export operation can be viewed in the Background operations view.

To export an agent log

  1. In the Navigation view, select Data Governance | Agents.
  2. In the Agents view (right pane), select the required agents.
  3. Select Export agent log from the Tasks view or right-click menu.
  4. In the Browse for folder dialog, select the location where the exported logs are to be stored.

    A compressed zip file is created in the location specified. Clicking this zip file displays a trace log document for the selected agents.

  5. Double-click the .dlog file to display the log viewer to view an agent's log entries.

Getting server logs

From the Managed hosts view in the Manager you can export the server logs to a location of your choosing. The log files are exported through a background operation and will exist once the background operation has completed. The export operation can be viewed in the Background operations view.

NOTE: Server logs retrieved using the Get All Logs task consist of the DataGovernanceEdition.Service.exe.dlog file and associated agent deployment logs.

To get server logs

  1. In the Navigation view, select Data Governance | Managed hosts.
  2. Select Get All Logs from the Tasks view or right-click menu.
  3. In the Browse for folder dialog, select the location where the exported logs are to be stored.

    A compressed zip file is created in the specified location. Clicking this zip file displays the Data Governance service log and an Agent Deployment Logs folder, which contains a log file for each agent deployed.

  4. Double-click the Data Governance service .dlog file to display the log viewer to view the service's log.
  5. Double-click an agent deployment log file to open Notepad to view the agent's deployment log.

Job queue shows that database needs to be compiled

On a new install or upgrade, upon Data Governance server startup, the job queue is placed on hold indicating that the database needs to be compiled.

Probable cause

The \TargetSystem\UNS\CreateNewRoot configuration setting must be enabled in order for a Data Governance Edition install to proceed successfully. If Data Governance Edition finds this setting to be disabled, it will mark it enabled; but the job queue will be placed on hold with a 'waiting for database compile' message.

As of Data Governance Edition 7.1, this configuration setting has been incorporated into the Settings.xml file. This Settings.xml file is distributed with One Identity Manager Data Governance Edition version 7.1 and when it is found to be enabled, the database compile step will proceed as excepted as part of the installation process.

Resolution

Locate the Settings.xml file (C:\<Identity Manager Build>\Setup\Editions\DGE\settings.xml) and ensure the following SQL command is present:

<Command Type="Sql">

     update DialogConfigParm

     set Enabled = 1

     where FullPath = 'TargetSystem\UNS\CreateNewRoot'

  </Command>

If it is not present, append this SQL command to the Settings.xml and run the DBCompiler.exe to remove the job queue hold. There should be no need to run the DBCompiler.exe on the next Data Governance Edition upgrade release.

If it is present, but set to disabled, run the DBCompiler.exe to remove the job queue hold.

Receiving unauthorized access violations

Probable cause

The employee is not configured properly.

Communication with the Data Governance server uses Windows Integrated authentication. Regardless of how you logged in to any client application ("viadmin"), calls to the Data Governance server are authenticated by looking at your interactive Windows login identity and finding an associated Employee record. The server validates the permissions and roles assigned to this Employee record, not the login that you used when connecting to the client application.

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