ArError2865_1 "Unable to update master account with reference to shadow account." found in DS Log file
说明
For one or more Users, attributes found in Microsoft Exchange or Microsoft Lync are not present (blank) in Active Roles Server.
原因
This issue has been noted to occur when there is a malfunction in either the "Built-in Policy - ERFM - Mailbox Management" or "Built-in Policy - Lync - Master Account Management" Policy Objects.
解决办法
Review the event description to identify the failed Active Roles Server master account.
In the Active Roles console, use the "All Tasks | Advanced Properties" command on the master account to clear the attribute that stores the reference to the shadow account. This is the adminDescription attribute by default, unless a custom attribute has been configured on the "Master Account" tab in the "Built-in Policy - ERFM - Mailbox Management" or "Built-in Policy - Lync - Master Account Management" Policy Object.
After the attribute in question has been cleared on the master account, use the Active Roles console to execute the "ERFM - Mailbox Management" or "Lync - Master Account Management" scheduled task, located in the "Configuration/Server Configuration/Scheduled Tasks/Builtin" container.
其他信息
Full error message as follows:
Unable to update master account with reference to shadow account.
%nMaster account: %1
%nShadow account: %2
%nActive Roles failed to remove shadow account's identifier from master account.
%nDetails:
Example:
Unable to update master account with reference to shadow account.
Master account: CM=account01,CN=OU,DC=first,DC=mycompany,DC=com
Shadow account: CM=account01,CN=OU,DC=second,DC=mycompany,DC=com
Active Roles failed to remove shadow account's identifier from master account.
Details: