Errors when creating "Send AS" or "Full Access" authorizations for ex0mail boxes if the authorization for a remotemail box is to be granted.
说明
* Steps to reproduce: Open an onprem mailbox (EX0Mailbox). For these, open the form "Assign send as permissions" or "Assign full access permissions" and select an ADS account that does not have an onprem mailbox (EX0Mailbox) but a remote mailbox (EXHMailbox).
* Expected result: The authorization can be saved.
* Different result: Error message.
* Error message/log: [1025012] Object (<name>) could not be saved! [810306] Error running 'OnSaving' in logic module 'EX0.Customizer.EX0MailboxFullAccessPerm'. [2106421] The mailbox and the Active Directory user account must belong to the same exchange organization.
原因
Since a remote mailbox also has an onprem part, this authorization must also be set up for such a mailbox.
The reason is that the Customizer currently only checks whether there is an EX0Mailbox for the selected ADSAccount in the same EX0Organization. "EXHMailbox" would also be allowed.
解决办法
Hotfix #36456 will be released to solve this issue.