Identity Manager 8.1 - Installation Guide

About this Guide One Identity Manager overview Installation prerequisites Installing One Identity Manager Installing and configuring the One Identity Manager Service Automatic updating of One Identity Manager Updating One Identity Manager Installing and updating an application server Installing the API Server Installing, configuring and maintaining the Web Portal Installing and updating the Manager web application Logging in to One Identity Manager tools Error handling Appendix: Creating a One Identity Manager database for a test or development environment from a database backup Appendix: Extended configuration of the Manager web application Appendix: Machine roles and installation packages Appendix: Settings for a new SQL Server database

Database errors when migrating a database in SQL Server AlwaysOn availability groups or database mirroring

Possible problems
  • The data does not start updating. The Configuration Wizard shows the message:

    The migration cannot be executed because a replication is currently running.

  • The following error occurs during a One Identity Manager schema update:

    Database error 1468: The operation cannot be performed on database "<database name>" because it is involved in a database mirroring session or an availability group. Some operations are not allowed on a database that is participating in a database mirroring session or in an availability group. ALTER DATABASE statement failed.

Cause

The database is part of an AlwaysOn availability group or is participating in a database mirroring.

Solution
  1. Remove the database from the AlwaysOn availability group or the database mirroring.

  2. Update the One Identity Manager schema.

  3. Re-admit the database to the AlwaysOn availability group or the database mirroring.

DBQueue Processor does not process tasks

Possible issues
  • After restoring a One Identity Manager database from a database backup, no more DBQueue Processor tasks are handled.
  • If the SQL Server in running on a virtual machine and the virtual machine is suspended, it is possible that no more DBQueue Processor tasks are handled after restarting the virtual machine.
Probable reason

The SQL Server Service Broker may not be reacting because of initializing the DBQueue Processor. The Service Broker is implemented for DBQueue Processor communications.

Solution

Execute the following steps using a suitable program for executing SQL queries in the database.

IMPORTANT: Select a user that you use for migrating the database to execute the SQL queries.

  1. Stop all DBQueue Processor components.

    exec QBM_PWatchDogPrepare 1

    go

    exec QBM_PDBQueuePrepare 1

    go

  2. Check whether other database sessions are active.

    select *

    from sys.sysprocesses p

    where dbid = DB_ID()

    and spid <> @@SPID

    If there are still sessions active, they must be closed first.

  3. Create a new ServiceBroker ID and enable message delivery.

    alter database <database name> set NEW_BROKER

    go

    alter database <database name> set enable_broker

    go

  4. Initializing the DBQueue Processor.

    exec QBM_PDBQueuePrepare 0,1

    go

    exec QBM_PWatchDogPrepare

    go

NOTE: If you restore a test or development database from a backup of another One Identity Manager database, these steps are executed by the Database Compiler. Manual execution of the steps is not necessary in this case. For more information, see Appendix: Creating a One Identity Manager database for a test or development environment from a database backup.

Message: Enter email address in configuration parameter

The parameter SenderAddress or Address contains the value <Enter email address in configuration parameter "..."> in a process for sending emails. Check process parameters in Job Queue Info.

The message is also sent to the One Identity Manager Service log file if extended error reporting in debug mode is configured for the One Identity Manager Service.

Probable Issue

The One Identity Manager sends email notifications about various actions taken within the system. The One Identity Manager email notification system is not completely configured.

Solution
  • Check the configuration parameters for the email notification system in the Base data | General | Configuration parameters category in Designer and customize the values.
Detailed information about this topic

Operations Support Web Portal is not displayed

Problem

An empty page is displayed in the Internet Explorer if the Operations Support Web Portal is opened with the URL.

Possible Cause

The Operations Support Web Portal should be displayed on an Intranet page and the Display intranet sites in compatibility view setting enabled in the web server.

Solution

In the configuration file (web.config) of the Web Portal application, extend the <system.webServer> section. Enter an attribute or compatibility mode.

<system.webServer>

...

<httpProtocol>

<customHeaders>

...

<add name="X-UA-Compatible" value="IE=11" />

...

</customHeaders>

</httpProtocol>

</system.webServer>

相关文档