Chat now with support
Chat with Support

Identity Manager 8.0 - Web Designer Reference Guide

Web Designer Editor Web Designer Structures and Functions The Web Designer Object Model Working with the Web Designer Web Project Configuration Options Customizing the Web Portal Basics of Web Designer Programming Compiling and Debugging Monitoring Frequent Tasks in the Web Portal

Working with Tabs

You can call up the Tabs... dialog box via the View menu. This provides you with an overview of tabs open in Web Designer.

To get an overview of open tabs

  1. Select Tabs... from the View menu.

    This opens the Tabs... dialog box with a list of open tabs.

  2. Mark the relevant tab you want to work with in the list and select one of the following actions:
    1. Enable
    2. Save
    3. Close tab

    TIP: You can select several tabs from the list by pressing the CTRL key as you mark each tab.

  3. Close the dialog box.

Context Menu Functions

To call up the context menu, right-click any node. The content of the menu depends on the type of node clicked ("context sensitive"). The top section of the context menu contains the node types and all available wizards that can be inserted into the currently selected node type.

The following wizards are available:

  • Insert bundling node

    Eases the task of structuring nodes hierarchically later on. A container-type node is generated above the currently selected node and the currently marked node is pasted into the new container.

  • Create Data Display

    This wizard creates forms, form elements, or grid views from available data. You will find this wizard on a Container-type node, for example. For more information, see Create Data Display.

  • Create/Embed Report

    Generates views from previously generated reports that are stored in the database. This wizard is available on action nodes. For more information, see Embedding Reports.

If a defined number of node types is exceeded, the nodes will be re-bundled beforehand. Some node types do not allow pasting of additional node types. In such cases, the context menu begins with the Cut function. All other functions are either available or grayed out, depending on the type of node and its position in the definition tree view.

Table 17: Functions in the Context Menu
Function Description
Cut This function is available insofar as the node in question was not added automatically to the definition tree. All nodes that are subordinate to the selected node are likewise cut.
Copy This function is always available. All subordinated nodes are likewise copied.
Paste This function is available if the clipboard contains a node that is also in the list of nodes that can be inserted in the currently selected node.
Delete This function is available insofar as the node in question was not added automatically to the definition tree. All nodes that are subordinate to the selected node are likewise deleted. You can multi-select nodes with the CTRL key to apply the function just once to all selected nodes.
Set breakpoint This function is available for controls and action nodes. Use this function in debugger mode to halt rendering at the selected points. You can multi-select nodes with the CTRL key to apply the function just once to all selected nodes.
Set bookmark This function opens a dialog box, in which to add a description of the bookmark. The object is then labeled with a bookmark in the definition tree view. For more information, see Bookmarks.
Export This function opens the Save as dialog box. In this process, the XML definition of the selected node and all of its subordinate nodes are saved in the file.
Import This function opens the File selection dialog box. where a previously exported definition tree structure can be selected. If the structure that is to be imported is compatible with the selected node, the structure will be inserted below the selected node.
Move up and Move down This functions shift the position of the selected node within its branch. These functions are available if the node in question was not inserted automatically and if the current position of the selected node allows for the realization of the relevant action.
Undo and Redo This functions are available if the relevant actions were carried out. The Undo function undoes the previous action, whereas the Redo function restores the state that existed prior to the realization of the Undo action.
Search object references

Search all references, which reference the current object. If the search is successful, the object references are displayed with position, module and object type.

If the search is for a reference within a collection, the results are grouped by related columns.

Search This function opens a dialog in which various search parameters can be entered (CTRL + F). For more information, see Search and replace.
Search next This function continues the current search using the current search parameters and in so doing marks the next relevant node. The search can also be carried out without opening the Search dialog box.

Working with the Preview

The preview window shows how a specific web application will look and respond in the browser. This means that the preview window can be used to test out the entire functionality of all buttons, links and so on. The displayed view is rendered using Internet Explorer, which is installed in the current client. The preview is displayed in the Web Designer preview area.

NOTE: Other browsers or other versions of the same browser can generate views other than that you see in the preview. To avoid display errors, conduct layout tests for the web application with specific browsers and browser versions.

NOTE: The preview function also writes data to the database or deletes database objects if this function is performed by the user. You need to be careful when you test the corresponding functions.

The preview window integrates a toolbar of its own, most of whose functions are used to manage debugging mode. When the debugger is activated, program functions are realized step by step rather than dynamically, thus enabling you to see which program step is actually being realized and the results yielded by the step. In addition, with the debugger activated, you can navigate at will to the query or data schema window.

Preview Functions

Table 18: Additional Toolbar Functions in the Preview
Icon Function

One node back/forward.

Use the Back and Forward buttons to navigate backwards or forwards between selected objects in the history in Web Portal preview mode. However, the history is not shown here.

Zoom in on preview.

The preview window switches to full screen mode. All other Web Designer windows are covered. The resolution defined for the preview window is disregarded here. This button is only active with the window in a docked state.

View HTML source.

The button is enabled after compiling has successfully completed. It opens a popup window containing the html source code generated by Web Designer. You can debug directly in the source code.

Window size: 1024 x 768

Customize window size.

This option is only available when the window is not docked. You can open the list with the arrow and select a value from the listed monitor resolutions. After selecting a resolution, the preview is automatically set to this size. This makes it possible to estimate whether the web application required scrollbars. The available space in the web browser to be used also plays a significant role as well as the number of items shown in the menu bar.

Use this button to swap from the mobile view to the desktop view.

Use this button to swap from the desktop to the mobile view.
Language The Language option allows you to set the language for the preview. You can choose from the languages in which you have logged in to Web Designer or other One Identity Manager tools. For more detailed information on login languages, see the One Identity Manager Configuration Guide.
Address bar

In the address bar, you can see the web application URL as in a browser. You can enter additional URL parameters either here or in the browser in which you opened the web application. Parameter examples:

  • imx_layout: The values "tablet" and "desktop" are options for this parameter.
  • imx_culture: The values "de-DE" and "en-US" are options for this parameter.

To enter a parameter with a value

  1. Click the address bar next to the URL in the preview window.
  2. Enter the following data, for example:

    &imx_layout=tablet

  3. Press Return.

    You preview changes to mobile view.

    Note: Entering a URL parameter works in the same way as the and buttons as well as the Language options box.

Related Documents