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Identity Manager 8.1 - Installation Guide

About this Guide One Identity Manager overview Installation prerequisites Installing One Identity Manager Installing and configuring the One Identity Manager Service Automatic updating of One Identity Manager Updating One Identity Manager Installing and updating an application server Installing the API Server Installing, configuring and maintaining the Web Portal Installing and updating the Manager web application Logging in to One Identity Manager tools Error handling Appendix: Creating a One Identity Manager database for a test or development environment from a database backup Appendix: Extended configuration of the Manager web application Appendix: Machine roles and installation packages Appendix: Settings for a new SQL Server database

Error handling

For more detailed information, see the One Identity Manager Process Monitoring and Troubleshooting Guide.

Displaying the transport history and checking the One Identity Manager version

For a schema installation or schema update with the Configuration Wizard, the migration date and the migration status are recorded in the transport history of the database.

When you import a transport package with the Database Transporter, the import date and description, the database version, and the transport package name are recorded in the transport history of the target database.

To display transport history

  • Start Designer and select Help | Transport history.

To obtain an overview of the system configuration

  • Start Designer or Manager and select Help | Info.

    The System information tab provides an overview of your current system administration and the installed modules with their versions.

    IMPORTANT: You will need to provide this information if you contact the Support Team.

    NOTE: If you have enabled vendor notification, this report is sent once a month to One Identity.
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Error messages when logging into One Identity Manager tools

Problem

When logging into a One Identity Manager tool, the following error message appears:

[810284] Failed to authenticate user.

[810015] Login for user {0} failed.

[810017] Wrong user name or password.

Possible Cause
  • The specified user is not supported by the selected authentication module.
  • The specified password is incorrect.
  • The employee used for the login is deactivated.
  • The user account used for the login is deactivated.
Solution

Check your login information.

Problem

When logging into a One Identity Manager tool, the following error message appears:

[810374] You are not allowed to run this application.

Cause

The One Identity Manager tools can only be started if the user has the relevant program function permissions. You are logging in with a system user ID that does not have the required permissions to start the program.

Possible solutions
  • Use a system user ID that has permissions to use the required program function to start the program.
  • Provide the system user with the required program function.
    • In Designer, check under Permissions | Program functions to see which permissions group contains the required program function.
    • For non-role-based logins: Add the system user to the permissions group in the Designer under Permissions | System users.
    • For role-based logins: Ensure that the user is assigned to the application role that contains the program function.

For detailed information about the One Identity Manager authentication modules, permissions groups and application roles, as well as program functions, see the One Identity Manager Authorization and Authentication Guide.

Error messages when installing and updating the One Identity Manager database

Before the installation or update of the One Identity Manager database starts, the Configuration Wizard checks the settings of the database server and the database required for the installation and operation of the One Identity Manager database. For more information, see Database server settings and the One Identity Manager database.

Some of these settings are corrected by the Configuration Wizard. If the correction is not possible, a corresponding message is issued in Configuration Wizard. In this case, correct the errors manually.

Table 51: Messages in Configuration Wizard before a database installation or update starts

Message

Solution

The SQL Server Agent did not start.

Start the SQL Server Agent in the SQL Server Service Management Portal. You can log in to an SQL Server Agent both with a domain user account (Domain users) with Windows authentication as well as with a local system account.

The database collation setting is not valid. ‘SQL_Latin1_General_CP1_CI_AS’ is required.

Set the Sort order (collation) database property to the value SQL_Latin1_General_CP1_CI_AS.

The migration cannot be executed because a replication is currently running.

For more information, see Database errors when migrating a database in SQL Server AlwaysOn availability groups or database mirroring.

The value in ‘DialogDatabase.DataOrigin’ is invalid. Start by running a database compilation.

Use the Database Compiler to regenerate a database ID and to compile the database. All parts of the database need to be recompiled. Make sure that all the code snippets and all processes are marked.

The Service Broker cannot be activated because other users are still active.

End the connections of other users to the database.

The database has no data-file group for in-memory OLTP.

Use the repair method to create a data-file group.

The database has not defined a file in the data-file group for in-memory OLTP.

Use the repair method to create a database file. The file is created in the directory of the data file (*.mdf).

The SQL Server has not activated in-memory OLTP.

Set the Is XTP Supported database server property to the True value.

The ‘Arithmetic Abort enabled’ database property is not enabled.

Set the Arithmetic Abort enabled database property to the True value.

The ‘Quoted Identifiers Enabled’ database property is not activated.

Set the Quoted Identifiers Enabled database property to the True value.

You cannot run a migration if the recovery model is not ‘Simple’.

Set the Recovery model database property to the Simple value.

The transaction mode cannot be set because other users are active.

End the connections of other users to the database.

The job queue and/or the DBQueue is not empty. Refer to the documentation for additional information and suggested solutions for this test.

Ensure that the Job queue processes and task in the DBQueue have been processed before starting the update. Use the Job Queue Info program to monitor process handling. For detailed information, see the One Identity Manager Process Monitoring and Troubleshooting Guide.

The Configuration Wizard has the option to ignore this message. Only use this option in test or development environments. By updating the database, modifications may be made, which result in not being able to handle the processes anymore.

The ‘viadmin’ system user must have a valid password that is not empty.

Make sure that the system user has a valid password.

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